[PATCH] mtd.h: Update the function name to 'rfree'

Since commit 8d38a8459b0d ("mtd: Rename free() to rfree()") the function has been renamed to rfree(), so update the description inside the mtd_oob_region structure as well.
Fixes: 8d38a8459b0d ("mtd: Rename free() to rfree()") Reported-by: Mikhail Kshevetskiy mikhail.kshevetskiy@iopsys.eu Signed-off-by: Fabio Estevam festevam@denx.de --- include/linux/mtd/mtd.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/linux/mtd/mtd.h b/include/linux/mtd/mtd.h index ff635bd716..09f5269887 100644 --- a/include/linux/mtd/mtd.h +++ b/include/linux/mtd/mtd.h @@ -122,7 +122,7 @@ struct mtd_oob_region { * @ecc: function returning an ECC region in the OOB area. * Should return -ERANGE if %section exceeds the total number of * ECC sections. - * @free: function returning a free region in the OOB area. + * @rfree: function returning a free region in the OOB area. * Should return -ERANGE if %section exceeds the total number of * free sections. */

Hi
On Fri, Oct 7, 2022 at 4:12 PM Fabio Estevam festevam@denx.de wrote:
Since commit 8d38a8459b0d ("mtd: Rename free() to rfree()") the function has been renamed to rfree(), so update the description inside the mtd_oob_region structure as well.
Fixes: 8d38a8459b0d ("mtd: Rename free() to rfree()") Reported-by: Mikhail Kshevetskiy mikhail.kshevetskiy@iopsys.eu Signed-off-by: Fabio Estevam festevam@denx.de
include/linux/mtd/mtd.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/linux/mtd/mtd.h b/include/linux/mtd/mtd.h index ff635bd716..09f5269887 100644 --- a/include/linux/mtd/mtd.h +++ b/include/linux/mtd/mtd.h @@ -122,7 +122,7 @@ struct mtd_oob_region {
- @ecc: function returning an ECC region in the OOB area.
Should return -ERANGE if %section exceeds the total number of
ECC sections.
- @free: function returning a free region in the OOB area.
*/
- @rfree: function returning a free region in the OOB area.
Should return -ERANGE if %section exceeds the total number of
free sections.
-- 2.25.1
Reviewed-by: Michael Trimarchi michael@amarulasolutions.com
Michael

HI
On Fri, Oct 7, 2022 at 4:13 PM Michael Nazzareno Trimarchi michael@amarulasolutions.com wrote:
Hi
On Fri, Oct 7, 2022 at 4:12 PM Fabio Estevam festevam@denx.de wrote:
Since commit 8d38a8459b0d ("mtd: Rename free() to rfree()") the function has been renamed to rfree(), so update the description inside the mtd_oob_region structure as well.
One minor on the patch subject
mtd: <here your comment>
Michael
Fixes: 8d38a8459b0d ("mtd: Rename free() to rfree()") Reported-by: Mikhail Kshevetskiy mikhail.kshevetskiy@iopsys.eu Signed-off-by: Fabio Estevam festevam@denx.de
include/linux/mtd/mtd.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/linux/mtd/mtd.h b/include/linux/mtd/mtd.h index ff635bd716..09f5269887 100644 --- a/include/linux/mtd/mtd.h +++ b/include/linux/mtd/mtd.h @@ -122,7 +122,7 @@ struct mtd_oob_region {
- @ecc: function returning an ECC region in the OOB area.
Should return -ERANGE if %section exceeds the total number of
ECC sections.
- @free: function returning a free region in the OOB area.
*/
- @rfree: function returning a free region in the OOB area.
Should return -ERANGE if %section exceeds the total number of
free sections.
-- 2.25.1
Reviewed-by: Michael Trimarchi michael@amarulasolutions.com
Michael
-- Michael Nazzareno Trimarchi Co-Founder & Chief Executive Officer M. +39 347 913 2170 michael@amarulasolutions.com __________________________________
Amarula Solutions BV Joop Geesinkweg 125, 1114 AB, Amsterdam, NL T. +31 (0)85 111 9172 info@amarulasolutions.com www.amarulasolutions.com
participants (2)
-
Fabio Estevam
-
Michael Nazzareno Trimarchi