[U-Boot-Users] [Patch] cmdbootz

[Note: command number assumes that the cmdximg patch was added before, please re-adapt otherwhise]
ChageLog:
* Patch by Holger Schurig, Robert Schwebel, 13 May 2004: Add a 'bootz' command to boot normal Linux zImages in case you don't need the features of U-Boot's uImage.
Robert

In message 20040513143623.GO27774@pengutronix.de you wrote:
- Patch by Holger Schurig, Robert Schwebel, 13 May 2004: Add a 'bootz' command to boot normal Linux zImages in case you don't need the features of U-Boot's uImage.
I reject this patch.
The newly added code is not added to any Makefile, so it does not get compiled at all.
If you add it, you will see that it is highly unportable; for example on a PowerPC system you get:
cmd_bootz.c:29:17: tag.h: No such file or directory
Most of the code seems to be for ARM only (functions like setup_*_tag() don't exist for PowerPC or MIPS or ...).
Please make this code usable for other architectures as well and resubmit.
Best regards,
Wolfgang Denk

On Thu, May 13, 2004 at 06:05:59PM +0200, Wolfgang Denk wrote:
Please make this code usable for other architectures as well and resubmit.
I've attached a version that tries to encapsulate the ARM specific stuff into CONFIG_ARM ifdefs; as I don't have any PowerPC toolchains here, could somebody with access to one and better knowledge about PPC kernel start mechanisms have a look at how things had to be done there?
Robert

In message 20040513171209.GU27774@pengutronix.de you wrote:
I've attached a version that tries to encapsulate the ARM specific stuff into CONFIG_ARM ifdefs; as I don't have any PowerPC toolchains here, could somebody with access to one and better knowledge about PPC kernel start mechanisms have a look at how things had to be done there?
I think this is not the right way to implement this -- as far as I can see most of this is duplicated code from "lib_arm/armlinux.c". if we continue that way and duplicate the code for other architectures as well we will and up with - well, a lot of duplicated code.
May I ask you to factor out the relevant code in "lib_arm/armlinux.c" so we have a set of functions which can be used by both the bootm and bootz commands?
And maybe we don't need to do even this - probably cmd_bootm.c can be split in a "header checking" and a "boot the image part" - so that the "bootm" command uses both, and "bootz" ignores the header checking.
Anyway - I think you get the idea: please do not duplicate lots of existing code.
Best regards,
Wolfgang Denk
participants (3)
-
Robert Schwebel
-
Robert Schwebel
-
Wolfgang Denk