[U-Boot] [PATCH] Fix FEC compile warning message

Provide function protocol for icache_invalid().
Signed-off-by: TsiChung Liew tsicliew@gmail.com --- drivers/net/mcffec.c | 4 ++++ 1 files changed, 4 insertions(+), 0 deletions(-)
diff --git a/drivers/net/mcffec.c b/drivers/net/mcffec.c index 64be5de..d3741a7 100644 --- a/drivers/net/mcffec.c +++ b/drivers/net/mcffec.c @@ -95,6 +95,10 @@ struct fec_info_s fec_info[] = { #endif };
+#ifdef CONFIG_SYS_UNIFY_CACHE +extern void icache_invalid(void); +#endif + int fec_send(struct eth_device *dev, volatile void *packet, int length); int fec_recv(struct eth_device *dev); int fec_init(struct eth_device *dev, bd_t * bd);

Dear TsiChung Liew,
In message 1248799132-29720-1-git-send-email-tsicliew@gmail.com you wrote:
Provide function protocol for icache_invalid().
Signed-off-by: TsiChung Liew tsicliew@gmail.com
drivers/net/mcffec.c | 4 ++++ 1 files changed, 4 insertions(+), 0 deletions(-)
diff --git a/drivers/net/mcffec.c b/drivers/net/mcffec.c index 64be5de..d3741a7 100644 --- a/drivers/net/mcffec.c +++ b/drivers/net/mcffec.c @@ -95,6 +95,10 @@ struct fec_info_s fec_info[] = { #endif };
+#ifdef CONFIG_SYS_UNIFY_CACHE +extern void icache_invalid(void); +#endif
Could you please rename this function into invalidate_icache(), and add a prototype declaration to include/asm-?/cache.h, like it is for example doene for PowerPC in include/asm-ppc/cache.h ?
I would like to see that all architectures use the same names for the same functions...
Thanks.
Best regards,
Wolfgang Denk

Wolfgang,
Yes, I will do that for the next merging window. Ignore this patch.
Thanks!
Best Regards, TsiChung
-----Original Message----- From: u-boot-bounces@lists.denx.de [mailto:u-boot-bounces@lists.denx.de] On Behalf Of Wolfgang Denk Sent: Tuesday, July 28, 2009 4:59 PM To: TsiChung Liew Cc: U-Boot; Ben Warre7n Subject: Re: [U-Boot] [PATCH] Fix FEC compile warning message
Dear TsiChung Liew,
In message 1248799132-29720-1-git-send-email-tsicliew@gmail.com you wrote:
Provide function protocol for icache_invalid().
Signed-off-by: TsiChung Liew tsicliew@gmail.com
drivers/net/mcffec.c | 4 ++++ 1 files changed, 4 insertions(+), 0 deletions(-)
diff --git a/drivers/net/mcffec.c b/drivers/net/mcffec.c index 64be5de..d3741a7 100644 --- a/drivers/net/mcffec.c +++ b/drivers/net/mcffec.c @@ -95,6 +95,10 @@ struct fec_info_s fec_info[] = { #endif };
+#ifdef CONFIG_SYS_UNIFY_CACHE +extern void icache_invalid(void); +#endif
Could you please rename this function into invalidate_icache(), and add a prototype declaration to include/asm-?/cache.h, like it is for example doene for PowerPC in include/asm-ppc/cache.h ?
I would like to see that all architectures use the same names for the same functions...
Thanks.
Best regards,
Wolfgang Denk
participants (3)
-
Liew Tsi Chung-R5AAHP
-
TsiChung Liew
-
Wolfgang Denk