[U-Boot] [PATCH 5/6] S5PC100: MTD: change env_address type

This patch changed the type from unsigned long to loff_t in the common/env_onenand.c.
The address type is changed from unsigned long to loff_t, but common/env_onenand.c is not yet. So, this patch is needed to get the accurate value of env_addr.
Signed-off-by: HeungJun, Kim riverful.kim@samsung.com
---
The env_relocate() in the common/env_common.c calls the env_relocate_spec() in the env_relocate_spec(), if use the onenand boot. But, env_addr's type is still unsigned long, thus it needed to be changed to loff_t.
common/env_onenand.c | 2 +- 1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/common/env_onenand.c b/common/env_onenand.c index ed77051..48089a9 100644 --- a/common/env_onenand.c +++ b/common/env_onenand.c @@ -58,7 +58,7 @@ uchar env_get_char_spec(int index)
void env_relocate_spec(void) { - unsigned long env_addr; + loff_t env_addr; int use_default = 0; size_t retlen;

On Thu, Jun 25, 2009 at 5:18 PM, HeungJun Kimriverful.kim@gmail.com wrote:
This patch changed the type from unsigned long to loff_t in the common/env_onenand.c.
The address type is changed from unsigned long to loff_t, but common/env_onenand.c is not yet. So, this patch is needed to get the accurate value of env_addr.
Signed-off-by: HeungJun, Kim riverful.kim@samsung.com
Acked-by: Kyungmin Park kyungmin.park@samsung.com

On 17:18 Thu 25 Jun , HeungJun Kim wrote:
This patch changed the type from unsigned long to loff_t in the common/env_onenand.c.
The address type is changed from unsigned long to loff_t, but common/env_onenand.c is not yet. So, this patch is needed to get the accurate value of env_addr.
Signed-off-by: HeungJun, Kim riverful.kim@samsung.com
this patch is not related to this series to please rename the title and send it separately
Best Regards, J.
participants (3)
-
HeungJun Kim
-
Jean-Christophe PLAGNIOL-VILLARD
-
Kyungmin Park