[U-Boot] [PATCH 2/2]: muas3001: added missing Maintainer entry

Hello,
[POWERPC] muas3001: added missing Maintainer entry correct SDRAM initialization values
Signed-off-by: Heiko Schocher hs@denx.de --- MAINTAINERS | 1 + include/configs/muas3001.h | 8 ++++++-- 2 files changed, 7 insertions(+), 2 deletions(-)
diff --git a/MAINTAINERS b/MAINTAINERS index cbe5c47..0c88117 100644 --- a/MAINTAINERS +++ b/MAINTAINERS @@ -361,6 +361,7 @@ Heiko Schocher hs@denx.de jupiter MPC5200 mgcoge MPC8247 mgsuvd MPC852 + muas3001 MPC8270 municse MPC5200 sc3 PPC405GP uc101 MPC5200 diff --git a/include/configs/muas3001.h b/include/configs/muas3001.h index f915e55..cde7b4e 100644 --- a/include/configs/muas3001.h +++ b/include/configs/muas3001.h @@ -331,7 +331,7 @@ /* Bank 1 - 60x bus SDRAM */ #define SDRAM_MAX_SIZE 0x08000000 /* max. 128 MB */ -#define CFG_GLOBAL_SDRAM_LIMIT (256 << 20) /* less than 256 MB */ +#define CFG_GLOBAL_SDRAM_LIMIT (128 << 20) /* less than 128 MB */
#define CFG_MPTPR 0x2800
@@ -351,7 +351,11 @@
/* SDRAM initialization values */ -#define CFG_OR1 0xfe002ec0 +#define CFG_OR1 ((~(CFG_GLOBAL_SDRAM_LIMIT-1) & ORxS_SDAM_MSK) |\ + ORxS_BPD_4 |\ + ORxS_ROWST_PBI1_A7 |\ + ORxS_NUMR_12) + #define CFG_PSDMR 0x004b36a3
/* IO on CS4 initialization values

Dear Heiko,
In message 489FDEF5.80004@denx.de you wrote:
[POWERPC] muas3001: added missing Maintainer entry correct SDRAM initialization values
Please fold this in the first patch, now that you have to respin it anyway.
Thanks.
Best regards,
Wolfgang Denk

Hello Jean-Chistophe,
your commit:
commit 00b1883a4cac59d97cd297b1a3a398db85982865
drivers/mtd: Move conditional compilation to Makefile
rename CFG_FLASH_CFI_DRIVER to CONFIG_FLASH_CFI_DRIVER
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD plagnioj@jcrosoft.com
overloocked 3 boards:
[hs@pollux u-boot]$ grep -lr CFG_FLASH_CFI_DRIVER include/configs/ include/configs/M5253DEMO.h include/configs/ml507.h include/configs/redwood.h [hs@pollux u-boot]$
following Patch fixes this:
Subject: [PATCH] [FIX] cfi: rename CFG_FLASH_CFI_DRIVER to CONFIG_FLASH_CFI_DRIVER for the 3 missing boards.
Signed-off-by: Heiko Schocher hs@denx.de --- include/configs/M5253DEMO.h | 2 +- include/configs/ml507.h | 2 +- include/configs/redwood.h | 2 +- 3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/include/configs/M5253DEMO.h b/include/configs/M5253DEMO.h index b91d7d6..f2c2317 100644 --- a/include/configs/M5253DEMO.h +++ b/include/configs/M5253DEMO.h @@ -206,7 +206,7 @@ * Amd/Atmel use 0x30 for sector erase, SST use 0x50. * 0x30 is block erase in SST */ -# define CFG_FLASH_CFI_DRIVER 1 +# define CONFIG_FLASH_CFI_DRIVER 1 # define CFG_FLASH_SIZE 0x800000 # define CFG_FLASH_CFI_WIDTH FLASH_CFI_16BIT # define CONFIG_FLASH_CFI_LEGACY diff --git a/include/configs/ml507.h b/include/configs/ml507.h index c653a51..f8cd499 100644 --- a/include/configs/ml507.h +++ b/include/configs/ml507.h @@ -110,7 +110,7 @@ #define CFG_FLASH_BASE XPAR_FLASH_MEM0_BASEADDR #define CFG_FLASH_SIZE (32*1024*1024) #define CFG_FLASH_CFI 1 -#define CFG_FLASH_CFI_DRIVER 1 +#define CONFIG_FLASH_CFI_DRIVER 1 #define CFG_FLASH_EMPTY_INFO 1 #define CFG_MAX_FLASH_BANKS 1 #define CFG_MAX_FLASH_SECT 259 diff --git a/include/configs/redwood.h b/include/configs/redwood.h index 32ed574..3de3587 100644 --- a/include/configs/redwood.h +++ b/include/configs/redwood.h @@ -165,7 +165,7 @@ * FLASH related *----------------------------------------------------------------------*/ #define CFG_FLASH_CFI /* The flash is CFI compatible */ -#define CFG_FLASH_CFI_DRIVER /* Use common CFI driver */ +#define CONFIG_FLASH_CFI_DRIVER /* Use common CFI driver */ #define CFG_FLASH_CFI_AMD_RESET 1 /* Use AMD (Spansion) reset cmd */
#define CFG_MAX_FLASH_BANKS 3 /* number of banks */

On 09:57 Tue 19 Aug , Heiko Schocher wrote:
Hello Jean-Chistophe,
your commit:
commit 00b1883a4cac59d97cd297b1a3a398db85982865
drivers/mtd: Move conditional compilation to Makefile
rename CFG_FLASH_CFI_DRIVER to CONFIG_FLASH_CFI_DRIVER
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD plagnioj@jcrosoft.com
overloocked 3 boards:
I've send a patch already for this
btw: There are board add after this commit
Best Regards, J.

Hello Jean-Chistophe,
Jean-Christophe PLAGNIOL-VILLARD schrieb:
On 09:57 Tue 19 Aug , Heiko Schocher wrote:
Hello Jean-Chistophe,
your commit:
commit 00b1883a4cac59d97cd297b1a3a398db85982865
drivers/mtd: Move conditional compilation to Makefile
rename CFG_FLASH_CFI_DRIVER to CONFIG_FLASH_CFI_DRIVER
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD plagnioj@jcrosoft.com
overloocked 3 boards:
I've send a patch already for this
Ups, sorry.
btw: There are board add after this commit
Yes, 2 are from me, thats, why I looked for this ;-)
bye Heiko

Dear Jean-Christophe PLAGNIOL-VILLARD,
In message 20080819082022.GA9094@game.jcrosoft.org you wrote:
On 09:57 Tue 19 Aug , Heiko Schocher wrote:
Hello Jean-Chistophe,
your commit:
commit 00b1883a4cac59d97cd297b1a3a398db85982865
drivers/mtd: Move conditional compilation to Makefile
rename CFG_FLASH_CFI_DRIVER to CONFIG_FLASH_CFI_DRIVER
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD plagnioj@jcrosoft.com
overloocked 3 boards:
I've send a patch already for this
Did you? Heiko's patch still applied...
Best regards,
Wolfgang Denk

On 02:03 Thu 21 Aug , Wolfgang Denk wrote:
Dear Jean-Christophe PLAGNIOL-VILLARD,
In message 20080819082022.GA9094@game.jcrosoft.org you wrote:
On 09:57 Tue 19 Aug , Heiko Schocher wrote:
Hello Jean-Chistophe,
your commit:
commit 00b1883a4cac59d97cd297b1a3a398db85982865
drivers/mtd: Move conditional compilation to Makefile
rename CFG_FLASH_CFI_DRIVER to CONFIG_FLASH_CFI_DRIVER
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD plagnioj@jcrosoft.com
overloocked 3 boards:
I've send a patch already for this
Did you? Heiko's patch still applied...
You do not applied it
the patch is [PATCH] coldfire: fix CFI drivers activation with new macro
Best Regards, J.

Dear Jean-Christophe PLAGNIOL-VILLARD,
In message 20080821064101.GI9094@game.jcrosoft.org you wrote:
Did you? Heiko's patch still applied...
You do not applied it
the patch is [PATCH] coldfire: fix CFI drivers activation with new macro
I did apply it, and before Heiko's patch. Your patch was applied as as v1.3.4-139-g0de0afb, while Heiko's is v1.3.4-148-g8f2b457 (i. e. 9 commits later).
Best regards,
Wolfgang Denk

Dear Heiko Schocher,
In message 48AA7CF5.20103@denx.de you wrote:
Subject: [PATCH] [FIX] cfi: rename CFG_FLASH_CFI_DRIVER to CONFIG_FLASH_CFI_DRIVER for the 3 missing boards.
Signed-off-by: Heiko Schocher hs@denx.de
include/configs/M5253DEMO.h | 2 +- include/configs/ml507.h | 2 +- include/configs/redwood.h | 2 +- 3 files changed, 3 insertions(+), 3 deletions(-)
Applied, thanks.
Best regards,
Wolfgang Denk
participants (3)
-
Heiko Schocher
-
Jean-Christophe PLAGNIOL-VILLARD
-
Wolfgang Denk