[U-Boot-Users] Register definition for MPC5200 WakeUp GPIO Data Input

For the MPC5200 processor, the include/mpc5xxxx.h file doesn't have an offset defined for the Wakeup GPIB Data Input Value register. It has only the output value register: #define MPC5XXX_WU_GPIO_DATA (MPC5XXX_WU_GPIO + 0x000c)
It seems like it should have been more accurately named with a direction suffix like this: #define MPC5XXX_WU_GPIO_DATA_O (MPC5XXX_WU_GPIO + 0x000c) #define MPC5XXX_WU_GPIO_DATA_I (MPC5XXX_WU_GPIO + 0x0020) consistent with how the input/output registers for simple GPIO were named.
Renaming MPC5XXX_WU_GPIO_DATA to MPC5XXX_WU_GPIO_DATA_O would affect many existing MPC5200-based boards.
Would the preferred approach be for me to submit a patch that adds MPC5XXX_WU_GPIO_DATA_O and MPC5XXX_WU_GPIO_DATA_I constants, and add a "deprecated" comment to MPC5XXX_WU_GPIO_DATA?
Would it be better to rename MPC5XXX_WU_GPIO_DATA to MPC5XXX_WU_GPIO_DATA_O, and modify the code for the referencing boards?
If neither, what would be the preferred approach?
(Sorry, for these questions about philosophy... I've never submitted patches before).
Thanks,
Ed Jubenville

In message GPECLCIGPLHEOMGPMCPAAEKKDNAA.edjubenville@adelphia.net you wrote:
It seems like it should have been more accurately named with a direction suffix like this: #define MPC5XXX_WU_GPIO_DATA_O (MPC5XXX_WU_GPIO + 0x000c) #define MPC5XXX_WU_GPIO_DATA_I (MPC5XXX_WU_GPIO + 0x0020) consistent with how the input/output registers for simple GPIO were named.
Agreed.
Renaming MPC5XXX_WU_GPIO_DATA to MPC5XXX_WU_GPIO_DATA_O would affect many existing MPC5200-based boards.
...but is a very simple and straightforward operation.
Would it be better to rename MPC5XXX_WU_GPIO_DATA to MPC5XXX_WU_GPIO_DATA_O, and modify the code for the referencing boards?
Yes.
Best regards,
Wolfgang Denk
participants (2)
-
Edward Jubenville
-
Wolfgang Denk