[U-Boot] [PATCH] usb: Define USB_MAX_STOR_DEV in only one place

We can define this in the header file and use it in usb_storage.c. There is no need to define it twice. Remove the #define from usb_storage.c.
Signed-off-by: Simon Glass sjg@chromium.org ---
common/usb_storage.c | 1 - 1 file changed, 1 deletion(-)
diff --git a/common/usb_storage.c b/common/usb_storage.c index e61a8c8..07fdf18 100644 --- a/common/usb_storage.c +++ b/common/usb_storage.c @@ -65,7 +65,6 @@ static const unsigned char us_direction[256/8] = { static ccb usb_ccb __attribute__((aligned(ARCH_DMA_MINALIGN))); static __u32 CBWTag;
-#define USB_MAX_STOR_DEV 7 static int usb_max_devs; /* number of highest available usb device */
static block_dev_desc_t usb_dev_desc[USB_MAX_STOR_DEV];

On Thursday, January 07, 2016 at 11:16:08 PM, Simon Glass wrote:
We can define this in the header file and use it in usb_storage.c. There is no need to define it twice. Remove the #define from usb_storage.c.
Signed-off-by: Simon Glass sjg@chromium.org
I guess you build tested this properly, right ?
Reviewed-by: Marek Vasut marex@denx.de
Best regards, Marek Vasut

Hi Marek,
On 7 January 2016 at 15:50, Marek Vasut marex@denx.de wrote:
On Thursday, January 07, 2016 at 11:16:08 PM, Simon Glass wrote:
We can define this in the header file and use it in usb_storage.c. There is no need to define it twice. Remove the #define from usb_storage.c.
Signed-off-by: Simon Glass sjg@chromium.org
I guess you build tested this properly, right ?
Yes. I was initially nervous that there might be a reason for the two definitions but I cannot see what it might be. So I think this patch is safe. Anyway I'll hold off applying it until early in the merge window.
Reviewed-by: Marek Vasut marex@denx.de
Best regards, Marek Vasut
Regards, Simon

On Friday, January 08, 2016 at 04:34:44 AM, Simon Glass wrote:
Hi Marek,
On 7 January 2016 at 15:50, Marek Vasut marex@denx.de wrote:
On Thursday, January 07, 2016 at 11:16:08 PM, Simon Glass wrote:
We can define this in the header file and use it in usb_storage.c. There is no need to define it twice. Remove the #define from usb_storage.c.
Signed-off-by: Simon Glass sjg@chromium.org
I guess you build tested this properly, right ?
Yes. I was initially nervous that there might be a reason for the two definitions but I cannot see what it might be. So I think this patch is safe. Anyway I'll hold off applying it until early in the merge window.
That's a good idea indeed. Thanks!
Best regards, Marek Vasut

On 8 January 2016 at 05:04, Marek Vasut marex@denx.de wrote:
On Friday, January 08, 2016 at 04:34:44 AM, Simon Glass wrote:
Hi Marek,
On 7 January 2016 at 15:50, Marek Vasut marex@denx.de wrote:
On Thursday, January 07, 2016 at 11:16:08 PM, Simon Glass wrote:
We can define this in the header file and use it in usb_storage.c. There is no need to define it twice. Remove the #define from usb_storage.c.
Signed-off-by: Simon Glass sjg@chromium.org
I guess you build tested this properly, right ?
Yes. I was initially nervous that there might be a reason for the two definitions but I cannot see what it might be. So I think this patch is safe. Anyway I'll hold off applying it until early in the merge window.
That's a good idea indeed. Thanks!
Best regards, Marek Vasut
Applied to u-boot-dm.
participants (2)
-
Marek Vasut
-
Simon Glass