[U-Boot-Users] [PATCH V2 0/9] SATA framework and FSL SATA support patch set

Hello all,
The patch set include two parts: 1. SATA framework support 2. The Freescale SATA controller support
I hope these patches to go v1.3.3.
Thanks, Dave
The following changes since commit 23e20aa6488e6c0622496549861bfdc74108debe: Yuri Tikhonov (1): lwmon5: Fix register test logic to match the specific GDC h/w.
are available in the git repository at:
git://git.ap.freescale.net/git/u-boot.git develop
Anton Vorontsov (1): mpc83xx: serdes setup routines
Dave Liu (8): ATA: Add the support for SATA framework ATA: Add the libata support ATA: Add the fis struct for SATA ATA: enable the sata init on bootup ATA: Add the readme for SATA command line mpc83xx: enable serdes1 for 837x SATA drivers: Add the support for Freescale SATA controller mpc83xx: enable the SATA interface on mpc837xemds board
board/freescale/mpc837xemds/mpc837xemds.c | 3 + common/Makefile | 1 + common/cmd_sata2.c | 206 +++++++ cpu/mpc83xx/Makefile | 2 +- cpu/mpc83xx/serdes.c | 156 +++++ disk/part.c | 14 + disk/part_dos.c | 2 + disk/part_iso.c | 1 + doc/README.sata | 69 +++ drivers/block/Makefile | 2 + drivers/block/fsl_sata.c | 921 ++++++++++++++++++++++ +++++++ drivers/block/fsl_sata.h | 374 ++++++++++++ drivers/block/libata.c | 158 +++++ include/asm-ppc/fsl_serdes.h | 25 + include/configs/MPC837XEMDS.h | 32 + include/fis.h | 156 +++++ include/libata.h | 207 +++++++ include/part.h | 3 + lib_ppc/board.c | 8 + 19 files changed, 2339 insertions(+), 1 deletions(-) create mode 100644 common/cmd_sata2.c create mode 100644 cpu/mpc83xx/serdes.c create mode 100644 doc/README.sata create mode 100644 drivers/block/fsl_sata.c create mode 100644 drivers/block/fsl_sata.h create mode 100644 drivers/block/libata.c create mode 100644 include/asm-ppc/fsl_serdes.h create mode 100644 include/fis.h create mode 100644 include/libata.h

Dear Dave,
in message 1206008182.3739.6.camel@localhost.localdomain you wrote:
The patch set include two parts:
- SATA framework support
- The Freescale SATA controller support
...
Dave Liu (8): ATA: Add the support for SATA framework
Why add new support? We already have some...
board/freescale/mpc837xemds/mpc837xemds.c | 3 + common/Makefile | 1 + common/cmd_sata2.c | 206 +++++++
Can you please explain why we need a new file common/cmd_sata2.c which duplicates a lot of functions of the already existing common/cmd_sata.c ?
I think this needs to be cleaned up. I will not accept multiple similar but conflicting implementations of the very same functions.
I hereby NAK the whole patch series.
Best regards,
Wolfgang Denk

-----Original Message----- From: Wolfgang Denk [mailto:wd@denx.de] Sent: Wed 3/26/2008 7:58 AM To: Liu Dave Cc: u-boot-external; Phillips Kim Subject: Re: [PATCH V2 0/9] SATA framework and FSL SATA support patch set
Dear Dave,
in message 1206008182.3739.6.camel@localhost.localdomain you wrote:
The patch set include two parts:
- SATA framework support
- The Freescale SATA controller support
...
Dave Liu (8): ATA: Add the support for SATA framework
Why add new support? We already have some...
[dave] really, I didn't find any SATA framework support in u-boot. if you are saying the cmd_sata.c. I don't agree it.
board/freescale/mpc837xemds/mpc837xemds.c | 3 + common/Makefile | 1 + common/cmd_sata2.c | 206 +++++++
Can you please explain why we need a new file common/cmd_sata2.c which duplicates a lot of functions of the already existing common/cmd_sata.c ?
[dave]the common/cmd_sata.c is more likely controller specificed driver, not sata framework. the cmd_sata2.c is more generic. can connect to different SATA controller driver.
I think this needs to be cleaned up. I will not accept multiple similar but conflicting implementations of the very same functions.
[dave]after the cmd_sata2.c is merge, I plan to move the cmd_sata.c to drivers/block.

Dear Dave,
in message 58A20A281BAF1047B4EAE68DE5C0BDC2C821F5@zch01exm21.fsl.freescale.net you wrote:
-----Original Message----- From: Wolfgang Denk [mailto:wd@denx.de] Sent: Wed 3/26/2008 7:58 AM To: Liu Dave Cc: u-boot-external; Phillips Kim Subject: Re: [PATCH V2 0/9] SATA framework and FSL SATA support patch > set
Dear Dave,
in message 1206008182.3739.6.camel@localhost.localdomain you wrote:
The patch set include two parts:
- SATA framework support
- The Freescale SATA controller support
...
Dave Liu (8): ATA: Add the support for SATA framework
Why add new support? We already have some...
[dave] really, I didn't find any SATA framework support in u-boot. if you are saying the cmd_sata.c. I don't agree it.
Your message is extremely difficult to read. Can you please use proper quoting? Please read http://www.netmeister.org/news/learn2quote.html if you need help...
board/freescale/mpc837xemds/mpc837xemds.c | 3 + common/Makefile | 1 + common/cmd_sata2.c | 206 +++++++
Can you please explain why we need a new file common/cmd_sata2.c which duplicates a lot of functions of the already existing common/cmd_sata.c ?
[dave]the common/cmd_sata.c is more likely controller specificed driver, not sata framework. the cmd_sata2.c is more generic. can connect to different SATA controller driver.
Maybe. But still both the existing common/cmd_sata.c and your new cmd_sata2.c implement the very same functions (like do_sata()) with more or less the same sub-commands etc.
I think this needs to be cleaned up. I will not accept multiple similar but conflicting implementations of the very same functions.
[dave]after the cmd_sata2.c is merge, I plan to move the cmd_sata.c to drivers/block.
Sorry, but this will not work. I will not add such duplicated code. Please add command level stuff to the (existing) common/cmd_sata.c file and do not add any new cmd_sata2.c which duplicates it. If necessary, clean up the code while you're there.
Best regards,
Wolfgang Denk

Your message is extremely difficult to read. Can you please use proper quoting? Please read http://www.netmeister.org/news/learn2quote.html if you need help...
[dave] sorry for that, I'm using the webmail to access my mailbox. the webmail is stupid.
[dave]the common/cmd_sata.c is more likely controller specificed driver, not sata framework. the cmd_sata2.c is more generic. can connect to different SATA controller driver.
Maybe. But still both the existing common/cmd_sata.c and your new cmd_sata2.c implement the very same functions (like do_sata()) with more or less the same sub-commands etc.
[dave] I think the same part is focusing on command line.
I think this needs to be cleaned up. I will not accept multiple similar but conflicting implementations of the very same functions.
[dave]after the cmd_sata2.c is merge, I plan to move the cmd_sata.c to drivers/block.
Sorry, but this will not work. I will not add such duplicated code. Please add command level stuff to the (existing) common/cmd_sata.c file and do not add any new cmd_sata2.c which duplicates it. If necessary, clean up the code while you're there.
[dave] if I choose current command/cmd_sata.c, and don't move the drivers part of cmd_sata.c to drivers/block. I think it will add extra-space for my image. so, the best choice is move the drivers part of cmd_sata.c to drivers/block. what do you think about it?

Dear Dave,
in message 58A20A281BAF1047B4EAE68DE5C0BDC2C821F6@zch01exm21.fsl.freescale.net you wrote:
[dave] sorry for that, I'm using the webmail to access my mailbox. the webmail is stupid.
I see :-(
Maybe. But still both the existing common/cmd_sata.c and your new cmd_sata2.c implement the very same functions (like do_sata()) with more or less the same sub-commands etc.
[dave] I think the same part is focusing on command line.
Not only. I think implementations of functions like sata_read() or sata_write() should be generic enough and not need to be duplicated.
[dave] if I choose current command/cmd_sata.c, and don't move the drivers part of cmd_sata.c to drivers/block. I think it will add extra-space for my image. so, the best choice is move the drivers part of cmd_sata.c to drivers/block. what do you think about it?
Probably you are right.
Best regards,
Wolfgang Denk
participants (3)
-
Dave Liu
-
Liu Dave
-
Wolfgang Denk