[PATCH] ata: ahci-pci: Replace magic constant by macro

Replace 0x1b21 by macro PCI_VENDOR_ID_ASMEDIA with the same value.
Signed-off-by: Pali Rohár pali@kernel.org --- drivers/ata/ahci-pci.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/ata/ahci-pci.c b/drivers/ata/ahci-pci.c index 797e0d570e88..5356b9d83d34 100644 --- a/drivers/ata/ahci-pci.c +++ b/drivers/ata/ahci-pci.c @@ -37,7 +37,7 @@ U_BOOT_DRIVER(ahci_pci) = {
static struct pci_device_id ahci_pci_supported[] = { { PCI_DEVICE_CLASS(PCI_CLASS_STORAGE_SATA_AHCI, ~0) }, - { PCI_DEVICE(0x1b21, 0x0611) }, + { PCI_DEVICE(PCI_VENDOR_ID_ASMEDIA, 0x0611) }, { PCI_DEVICE(PCI_VENDOR_ID_MARVELL, 0x6121) }, { PCI_DEVICE(PCI_VENDOR_ID_MARVELL, 0x6145) }, {},

On Mon, 5 Dec 2022 at 01:32, Pali Rohár pali@kernel.org wrote:
Replace 0x1b21 by macro PCI_VENDOR_ID_ASMEDIA with the same value.
Signed-off-by: Pali Rohár pali@kernel.org
drivers/ata/ahci-pci.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
Reviewed-by: Simon Glass sjg@chromium.org

On Sun, Dec 04, 2022 at 01:31:08PM +0100, Pali Rohár wrote:
Replace 0x1b21 by macro PCI_VENDOR_ID_ASMEDIA with the same value.
Signed-off-by: Pali Rohár pali@kernel.org Reviewed-by: Simon Glass sjg@chromium.org
Applied to u-boot/next, thanks!
participants (3)
-
Pali Rohár
-
Simon Glass
-
Tom Rini