[PATCH] debug_uart: Add CR before and after announce string

Add linefeeds before and after the announce string. This makes the output easier to read, especially if some text follows the announce message without a specific additional CR.
Signed-off-by: Stefan Roese sr@denx.de --- include/debug_uart.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/debug_uart.h b/include/debug_uart.h index 4d1c58075c..714b369e6f 100644 --- a/include/debug_uart.h +++ b/include/debug_uart.h @@ -112,7 +112,7 @@ void printhex8(unsigned int value); void printdec(unsigned int value);
#ifdef CONFIG_DEBUG_UART_ANNOUNCE -#define _DEBUG_UART_ANNOUNCE printascii("<debug_uart> "); +#define _DEBUG_UART_ANNOUNCE printascii("\n<debug_uart>\n"); #else #define _DEBUG_UART_ANNOUNCE #endif

On Fri, May 15, 2020 at 1:09 PM Stefan Roese sr@denx.de wrote:
Add linefeeds before and after the announce string. This makes the output easier to read, especially if some text follows the announce message without a specific additional CR.
Signed-off-by: Stefan Roese sr@denx.de
include/debug_uart.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
Reviewed-by: Bin Meng bmeng.cn@gmail.com

On Fri, May 15, 2020 at 07:09:03AM +0200, Stefan Roese wrote:
Add linefeeds before and after the announce string. This makes the output easier to read, especially if some text follows the announce message without a specific additional CR.
Signed-off-by: Stefan Roese sr@denx.de Reviewed-by: Bin Meng bmeng.cn@gmail.com
Applied to u-boot/master, thanks!
participants (3)
-
Bin Meng
-
Stefan Roese
-
Tom Rini