[U-Boot] [PATCH 0/4] cfi_flash: A bit of cleanup and code simplification

Hi,
following are a few patches with minor code clean-up and simplification for the cfi_flash driver. Especially the usage of CONFIG_SYS_MAX_FLASH_BANKS_DETECT to support dynamic flash bank number detection is reworked a bit. Additionally, now the flash base address list can be dynamically changed if needed as well.
Here the shortlog:
Stefan Roese (4): cfi_flash: Simplify flash_get_info() cfi_flash: Add weak default for cfi_flash_bank_addr() cfi_flash: Simplify dynamic flash bank number detection cfi_flash: Remove uneccessary #ifdef CONFIG_SYS_MAX_FLASH_BANKS_DETECT
board/esd/apc405/apc405.c | 6 ++---- board/tqc/tqm834x/tqm834x.c | 12 +++++------- common/cmd_bootm.c | 1 + common/cmd_flash.c | 10 ++-------- common/flash.c | 1 + drivers/mtd/cfi_flash.c | 32 +++++++++++++++----------------- drivers/mtd/cfi_mtd.c | 10 +--------- include/configs/APC405.h | 6 ------ include/configs/IDS8247.h | 3 +-- include/configs/TQM834x.h | 4 ---- include/flash.h | 2 ++ include/mtd/cfi_flash.h | 18 ++++++++++++++++++ 12 files changed, 48 insertions(+), 57 deletions(-)
As you can see, these patches touch non-cfi related files too. If nobody objects, I'll collect these patches in my cfi-flash repository for the next merge window.
Cheers, Stefan
-- DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Zundel HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany Phone: (+49)-8142-66989-0 Fax: (+49)-8142-66989-80 Email: office@denx.de

On Tuesday 31 August 2010 13:33:23 Stefan Roese wrote:
following are a few patches with minor code clean-up and simplification for the cfi_flash driver. Especially the usage of CONFIG_SYS_MAX_FLASH_BANKS_DETECT to support dynamic flash bank number detection is reworked a bit. Additionally, now the flash base address list can be dynamically changed if needed as well.
Here the shortlog:
Stefan Roese (4): cfi_flash: Simplify flash_get_info() cfi_flash: Add weak default for cfi_flash_bank_addr() cfi_flash: Simplify dynamic flash bank number detection cfi_flash: Remove uneccessary #ifdef CONFIG_SYS_MAX_FLASH_BANKS_DETECT
The patch-series applied to u-boot-cfi-flash/next. Thanks.
Cheers, Stefan
-- DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Zundel HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany Phone: (+49)-8142-66989-0 Fax: (+49)-8142-66989-80 Email: office@denx.de

On 2010/09/16 4:18 PM, Stefan Roese wrote:
On Tuesday 31 August 2010 13:33:23 Stefan Roese wrote:
following are a few patches with minor code clean-up and simplification for the cfi_flash driver. Especially the usage of CONFIG_SYS_MAX_FLASH_BANKS_DETECT to support dynamic flash bank number detection is reworked a bit. Additionally, now the flash base address list can be dynamically changed if needed as well.
Here the shortlog:
Stefan Roese (4): cfi_flash: Simplify flash_get_info() cfi_flash: Add weak default for cfi_flash_bank_addr() cfi_flash: Simplify dynamic flash bank number detection cfi_flash: Remove uneccessary #ifdef CONFIG_SYS_MAX_FLASH_BANKS_DETECT
The patch-series applied to u-boot-cfi-flash/next. Thanks.
Cheers, Stefan
Hi Stefan,
Have you had any thoughts about what the CONFIG_CFI option should be called for the odd flash arrangement on my DNS323? If you let me know what to call it, I'll submit a patch.
Thanks
Rogan

Hi Rogan,
On Thursday 16 September 2010 16:21:05 Rogan Dawes wrote:
Have you had any thoughts about what the CONFIG_CFI option should be called for the odd flash arrangement on my DNS323? If you let me know what to call it, I'll submit a patch.
Sorry, but no, I have no idea right now. IIRC, this patch I sent you was more a hack for testing and not ready for upstream acceptance. But please go ahead and send such a patch, with a name that fits it best form your point of view. Perhaps others have an idea how best to implement this in a clean way. And at least its available on the list for reference.
Cheers, Stefan
-- DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Zundel HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany Phone: (+49)-8142-66989-0 Fax: (+49)-8142-66989-80 Email: office@denx.de

On 2010/09/16 5:10 PM, Stefan Roese wrote:
Hi Rogan,
On Thursday 16 September 2010 16:21:05 Rogan Dawes wrote:
Have you had any thoughts about what the CONFIG_CFI option should be called for the odd flash arrangement on my DNS323? If you let me know what to call it, I'll submit a patch.
Sorry, but no, I have no idea right now. IIRC, this patch I sent you was more a hack for testing and not ready for upstream acceptance. But please go ahead and send such a patch, with a name that fits it best form your point of view. Perhaps others have an idea how best to implement this in a clean way. And at least its available on the list for reference.
Cheers, Stefan
Hi Stefan,
My problem is that I don't know how to describe the odd address line connection setup. That would lead to a decent name, and a suitable patch would follow shortly thereafter.
Rogan
participants (2)
-
Rogan Dawes
-
Stefan Roese