[U-Boot] [PATCH] cmd_sf: rename "speed" to "hz"

The term "hz" is used everywhere else when talking about the frequency of the SPI bus, so have the sf command use it as well to stay consistent. It even presents itself as "hz" when showing user help.
Signed-off-by: Mike Frysinger vapier@gentoo.org --- common/cmd_sf.c | 10 +++++----- 1 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/common/cmd_sf.c b/common/cmd_sf.c index 8c0a751..902e51d 100644 --- a/common/cmd_sf.c +++ b/common/cmd_sf.c @@ -8,8 +8,8 @@
#include <asm/io.h>
-#ifndef CONFIG_SF_DEFAULT_SPEED -# define CONFIG_SF_DEFAULT_SPEED 1000000 +#ifndef CONFIG_SF_DEFAULT_HZ +# define CONFIG_SF_DEFAULT_HZ 1000000 #endif #ifndef CONFIG_SF_DEFAULT_MODE # define CONFIG_SF_DEFAULT_MODE SPI_MODE_3 @@ -21,7 +21,7 @@ static int do_spi_flash_probe(int argc, char *argv[]) { unsigned int bus = 0; unsigned int cs; - unsigned int speed = CONFIG_SF_DEFAULT_SPEED; + unsigned int hz = CONFIG_SF_DEFAULT_HZ; unsigned int mode = CONFIG_SF_DEFAULT_MODE; char *endp; struct spi_flash *new; @@ -43,7 +43,7 @@ static int do_spi_flash_probe(int argc, char *argv[]) }
if (argc >= 3) { - speed = simple_strtoul(argv[2], &endp, 0); + hz = simple_strtoul(argv[2], &endp, 0); if (*argv[2] == 0 || *endp != 0) goto usage; } @@ -53,7 +53,7 @@ static int do_spi_flash_probe(int argc, char *argv[]) goto usage; }
- new = spi_flash_probe(bus, cs, speed, mode); + new = spi_flash_probe(bus, cs, hz, mode); if (!new) { printf("Failed to initialize SPI flash at %u:%u\n", bus, cs); return 1;

Dear Mike Frysinger,
In message 1229034488-26048-1-git-send-email-vapier@gentoo.org you wrote:
The term "hz" is used everywhere else when talking about the frequency of the SPI bus, so have the sf command use it as well to stay consistent. It even presents itself as "hz" when showing user help.
Signed-off-by: Mike Frysinger vapier@gentoo.org
common/cmd_sf.c | 10 +++++----- 1 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/common/cmd_sf.c b/common/cmd_sf.c index 8c0a751..902e51d 100644 --- a/common/cmd_sf.c +++ b/common/cmd_sf.c @@ -8,8 +8,8 @@
#include <asm/io.h>
-#ifndef CONFIG_SF_DEFAULT_SPEED -# define CONFIG_SF_DEFAULT_SPEED 1000000 +#ifndef CONFIG_SF_DEFAULT_HZ +# define CONFIG_SF_DEFAULT_HZ 1000000
I consider "FREQ" (and even "SPEED) a much better name than "HZ".
"HZ" is the unit of what you are measuring, not a name for what you are measuring.
NAK.
Best regards,
Wolfgang Denk

On Thursday 11 December 2008 18:59:46 Wolfgang Denk wrote:
In message Mike Frysinger you wrote:
The term "hz" is used everywhere else when talking about the frequency of the SPI bus, so have the sf command use it as well to stay consistent. It even presents itself as "hz" when showing user help.
Signed-off-by: Mike Frysinger vapier@gentoo.org
common/cmd_sf.c | 10 +++++----- 1 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/common/cmd_sf.c b/common/cmd_sf.c index 8c0a751..902e51d 100644 --- a/common/cmd_sf.c +++ b/common/cmd_sf.c @@ -8,8 +8,8 @@
#include <asm/io.h>
-#ifndef CONFIG_SF_DEFAULT_SPEED -# define CONFIG_SF_DEFAULT_SPEED 1000000 +#ifndef CONFIG_SF_DEFAULT_HZ +# define CONFIG_SF_DEFAULT_HZ 1000000
I consider "FREQ" (and even "SPEED) a much better name than "HZ".
"HZ" is the unit of what you are measuring, not a name for what you are measuring.
then they should all be converted. not 90% using hz and 10% using something else. "speed" is bad as it doesnt convey the unit while "hz" is pretty clear. -mike

Dear Mike Frysinger,
In message 200812112130.02918.vapier@gentoo.org you wrote:
-#ifndef CONFIG_SF_DEFAULT_SPEED -# define CONFIG_SF_DEFAULT_SPEED 1000000 +#ifndef CONFIG_SF_DEFAULT_HZ +# define CONFIG_SF_DEFAULT_HZ 1000000
I consider "FREQ" (and even "SPEED) a much better name than "HZ".
"HZ" is the unit of what you are measuring, not a name for what you are measuring.
then they should all be converted. not 90% using hz and 10% using something
Agreed.
else. "speed" is bad as it doesnt convey the unit while "hz" is pretty clear.
You are right, but that could be mentioned in the documentation then...
Best regards,
Wolfgang Denk

On Friday 12 December 2008 02:22:16 Wolfgang Denk wrote:
In message 200812112130.02918.vapier@gentoo.org you wrote:
-#ifndef CONFIG_SF_DEFAULT_SPEED -# define CONFIG_SF_DEFAULT_SPEED 1000000 +#ifndef CONFIG_SF_DEFAULT_HZ +# define CONFIG_SF_DEFAULT_HZ 1000000
I consider "FREQ" (and even "SPEED) a much better name than "HZ".
"HZ" is the unit of what you are measuring, not a name for what you are measuring.
then they should all be converted. not 90% using hz and 10% using something
Agreed.
else. "speed" is bad as it doesnt convey the unit while "hz" is pretty clear.
You are right, but that could be mentioned in the documentation then...
that seems silly to me. we can either have self-explaining defines, or confusing ones which requires people to read the documentation to figure out ? -mike

Mike Frysinger wrote:
On Thursday 11 December 2008 18:59:46 Wolfgang Denk wrote:
In message Mike Frysinger you wrote:
The term "hz" is used everywhere else when talking about the frequency of the SPI bus, so have the sf command use it as well to stay consistent. It even presents itself as "hz" when showing user help.
Signed-off-by: Mike Frysinger vapier@gentoo.org
common/cmd_sf.c | 10 +++++----- 1 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/common/cmd_sf.c b/common/cmd_sf.c index 8c0a751..902e51d 100644 --- a/common/cmd_sf.c +++ b/common/cmd_sf.c @@ -8,8 +8,8 @@
#include <asm/io.h>
-#ifndef CONFIG_SF_DEFAULT_SPEED -# define CONFIG_SF_DEFAULT_SPEED 1000000 +#ifndef CONFIG_SF_DEFAULT_HZ +# define CONFIG_SF_DEFAULT_HZ 1000000
I consider "FREQ" (and even "SPEED) a much better name than "HZ".
"HZ" is the unit of what you are measuring, not a name for what you are measuring.
then they should all be converted. not 90% using hz and 10% using something else. "speed" is bad as it doesnt convey the unit while "hz" is pretty clear. -mike
Maybe I'm being pedantic or have drunk too much coffee, but "clk" (clock rate, _expressed_ in Hz) is better than "speed" IMHO. "bps" (bits per second) is another alternative, although it has its own problems if the data rate is different when sending "0" bits vs. "1" bits (e.g. 1-wire).
Best regards, gvb

Mike Frysinger wrote:
The term "hz" is used everywhere else when talking about the frequency of the SPI bus, so have the sf command use it as well to stay consistent. It even presents itself as "hz" when showing user help.
Signed-off-by: Mike Frysinger vapier@gentoo.org
I like it. "hz" makes it perfectly clear what the value means.
Acked-by: Haavard Skinnemoen haavard.skinnemoen@atmel.com
participants (4)
-
Haavard Skinnemoen
-
Jerry Van Baren
-
Mike Frysinger
-
Wolfgang Denk