[U-Boot] [PATCH 0/3] Fix multipe typos "choosen" instead of "chosen" in dts/code

The dts files for NXP/Freescale Vybrid series were broken. Fixed some other typos in comments & printfs to.
Alexander Merkle (3): Fix typo in chosen parameter in vf610-twr.dts Fix typo in chosen parameter of pcm052.dts Fix typo choosen in comments and printf logs
arch/arm/dts/pcm052.dts | 2 +- arch/arm/dts/vf610-twr.dts | 2 +- common/menu.c | 2 +- drivers/ddr/fsl/lc_common_dimm_params.c | 4 ++-- 4 files changed, 5 insertions(+), 5 deletions(-)

Fix typo "choosen" instead of "chosen" in vf610-twr.dts. Fixes boot process and terminal output for Vybrid series.
Signed-off-by: Alexander Merkle alexander.merkle@lauterbach.com ---
arch/arm/dts/vf610-twr.dts | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/dts/vf610-twr.dts b/arch/arm/dts/vf610-twr.dts index a4ccbcb..237aa8d 100644 --- a/arch/arm/dts/vf610-twr.dts +++ b/arch/arm/dts/vf610-twr.dts @@ -11,7 +11,7 @@ model = "VF610 Tower Board"; compatible = "fsl,vf610-twr", "fsl,vf610";
- choosen { + chosen { stdout-path = &uart1; };

On Thu, Mar 17, 2016 at 10:44 PM, Alexander Merkle alexander.merkle@lauterbach.com wrote:
Fix typo "choosen" instead of "chosen" in vf610-twr.dts. Fixes boot process and terminal output for Vybrid series.
Signed-off-by: Alexander Merkle alexander.merkle@lauterbach.com
arch/arm/dts/vf610-twr.dts | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
Reviewed-by: Bin Meng bmeng.cn@gmail.com

On Thu, Mar 17, 2016 at 03:44:45PM +0100, Alexander Merkle wrote:
Fix typo "choosen" instead of "chosen" in vf610-twr.dts. Fixes boot process and terminal output for Vybrid series.
Signed-off-by: Alexander Merkle alexander.merkle@lauterbach.com Reviewed-by: Bin Meng bmeng.cn@gmail.com
Applied to u-boot/master, thanks!

Fix typo "choosen" instead of "chosen" in pcm052.dts. Not tested but should fix boot process and terminal output.
Signed-off-by: Alexander Merkle alexander.merkle@lauterbach.com ---
arch/arm/dts/pcm052.dts | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/dts/pcm052.dts b/arch/arm/dts/pcm052.dts index 0475f1f..0985587 100644 --- a/arch/arm/dts/pcm052.dts +++ b/arch/arm/dts/pcm052.dts @@ -11,7 +11,7 @@ model = "Phytec phyCORE-Vybrid"; compatible = "phytec,pcm052", "fsl,vf610";
- choosen { + chosen { stdout-path = &uart1; };

On Thu, Mar 17, 2016 at 10:44 PM, Alexander Merkle alexander.merkle@lauterbach.com wrote:
Fix typo "choosen" instead of "chosen" in pcm052.dts. Not tested but should fix boot process and terminal output.
Signed-off-by: Alexander Merkle alexander.merkle@lauterbach.com
arch/arm/dts/pcm052.dts | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
Reviewed-by: Bin Meng bmeng.cn@gmail.com

On Thu, Mar 17, 2016 at 03:44:46PM +0100, Alexander Merkle wrote:
Fix typo "choosen" instead of "chosen" in pcm052.dts. Not tested but should fix boot process and terminal output.
Signed-off-by: Alexander Merkle alexander.merkle@lauterbach.com Reviewed-by: Bin Meng bmeng.cn@gmail.com
Applied to u-boot/master, thanks!

Minor change: chosen is written with one "o". No code change here, only comment & printf.
Signed-off-by: Alexander Merkle alexander.merkle@lauterbach.com ---
common/menu.c | 2 +- drivers/ddr/fsl/lc_common_dimm_params.c | 4 ++-- 2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/common/menu.c b/common/menu.c index eda96d6..c53030f 100644 --- a/common/menu.c +++ b/common/menu.c @@ -350,7 +350,7 @@ int menu_item_add(struct menu *m, char *item_key, void *item_data) * make it obvious what the key for each entry is. * * item_choice - If not NULL, will be called when asking the user to choose an - * item. Returns a key string corresponding to the choosen item or NULL if + * item. Returns a key string corresponding to the chosen item or NULL if * no item has been selected. * * item_choice_data - Will be passed as the argument to the item_choice function diff --git a/drivers/ddr/fsl/lc_common_dimm_params.c b/drivers/ddr/fsl/lc_common_dimm_params.c index 47ad4e5..850c8f6 100644 --- a/drivers/ddr/fsl/lc_common_dimm_params.c +++ b/drivers/ddr/fsl/lc_common_dimm_params.c @@ -60,8 +60,8 @@ compute_cas_latency(const unsigned int ctrl_num, * 18ns for all DDR4 speed grades. */ if (caslat_actual * mclk_ps > taamax) { - printf("The choosen cas latency %d is too large\n", - caslat_actual); + printf("The chosen cas latency %d is too large\n", + caslat_actual); } outpdimm->lowest_common_spd_caslat = caslat_actual; debug("lowest_common_spd_caslat is 0x%x\n", caslat_actual);

On Thu, Mar 17, 2016 at 10:44 PM, Alexander Merkle alexander.merkle@lauterbach.com wrote:
Minor change: chosen is written with one "o". No code change here, only comment & printf.
Signed-off-by: Alexander Merkle alexander.merkle@lauterbach.com
common/menu.c | 2 +- drivers/ddr/fsl/lc_common_dimm_params.c | 4 ++-- 2 files changed, 3 insertions(+), 3 deletions(-)
Reviewed-by: Bin Meng bmeng.cn@gmail.com

On Thu, Mar 17, 2016 at 03:44:47PM +0100, Alexander Merkle wrote:
Minor change: chosen is written with one "o". No code change here, only comment & printf.
Signed-off-by: Alexander Merkle alexander.merkle@lauterbach.com Reviewed-by: Bin Meng bmeng.cn@gmail.com
Applied to u-boot/master, thanks!

On 03/17/2016 08:14 PM, Alexander Merkle wrote:
The dts files for NXP/Freescale Vybrid series were broken. Fixed some other typos in comments & printfs to.
I guess this is not typo the node name is 'chosen'. Some documentation is here[1].
[1] http://lxr.free-electrons.com/source/Documentation/devicetree/bindings/chose...
Alexander Merkle (3): Fix typo in chosen parameter in vf610-twr.dts Fix typo in chosen parameter of pcm052.dts Fix typo choosen in comments and printf logs
arch/arm/dts/pcm052.dts | 2 +- arch/arm/dts/vf610-twr.dts | 2 +- common/menu.c | 2 +- drivers/ddr/fsl/lc_common_dimm_params.c | 4 ++-- 4 files changed, 5 insertions(+), 5 deletions(-)

Hi,
may be the subject is misleading. The DTS/DTB entry should be named "chosen" but it was "choosen" with "oo" in the git master. Have a look to the commits.
diff --git a/arch/arm/dts/vf610-twr.dts b/arch/arm/dts/vf610-twr.dts index a4ccbcb..237aa8d 100644 --- a/arch/arm/dts/vf610-twr.dts +++ b/arch/arm/dts/vf610-twr.dts @@ -11,7 +11,7 @@ model = "VF610 Tower Board"; compatible = "fsl,vf610-twr", "fsl,vf610";
- choosen { + chosen { stdout-path = &uart1; };
Regards,
Alex
Alexander Merkle System Engineer Lauterbach GmbH Altlaufstraße 40 85635 Hoehenkirchen-Siegertsbrunn Germany Tel +49 8102 9876-147 mailto:alexander.merkle@lauterbach.com http://www.lauterbach.com
On 17.03.2016 16:06, Bhuvanchandra DV wrote:
On 03/17/2016 08:14 PM, Alexander Merkle wrote:
The dts files for NXP/Freescale Vybrid series were broken. Fixed some other typos in comments & printfs to.
I guess this is not typo the node name is 'chosen'. Some documentation is here[1].
[1] http://lxr.free-electrons.com/source/Documentation/devicetree/bindings/chose...
Alexander Merkle (3): Fix typo in chosen parameter in vf610-twr.dts Fix typo in chosen parameter of pcm052.dts Fix typo choosen in comments and printf logs
arch/arm/dts/pcm052.dts | 2 +- arch/arm/dts/vf610-twr.dts | 2 +- common/menu.c | 2 +- drivers/ddr/fsl/lc_common_dimm_params.c | 4 ++-- 4 files changed, 5 insertions(+), 5 deletions(-)

On 03/17/2016 08:50 PM, Alexander Merkle wrote:
Hi,
may be the subject is misleading. The DTS/DTB entry should be named "chosen" but it was "choosen" with "oo" in the git master. Have a look to the commits.
My bad! got it.
diff --git a/arch/arm/dts/vf610-twr.dts b/arch/arm/dts/vf610-twr.dts index a4ccbcb..237aa8d 100644 --- a/arch/arm/dts/vf610-twr.dts +++ b/arch/arm/dts/vf610-twr.dts @@ -11,7 +11,7 @@ model = "VF610 Tower Board"; compatible = "fsl,vf610-twr", "fsl,vf610";
- choosen {
- chosen { stdout-path = &uart1; };
Regards,
Alex
Alexander Merkle System Engineer Lauterbach GmbH Altlaufstraße 40 85635 Hoehenkirchen-Siegertsbrunn Germany Tel +49 8102 9876-147 mailto:alexander.merkle@lauterbach.com http://www.lauterbach.com
On 17.03.2016 16:06, Bhuvanchandra DV wrote:
On 03/17/2016 08:14 PM, Alexander Merkle wrote:
The dts files for NXP/Freescale Vybrid series were broken. Fixed some other typos in comments & printfs to.
I guess this is not typo the node name is 'chosen'. Some documentation is here[1].
[1] http://lxr.free-electrons.com/source/Documentation/devicetree/bindings/chose...
Alexander Merkle (3): Fix typo in chosen parameter in vf610-twr.dts Fix typo in chosen parameter of pcm052.dts Fix typo choosen in comments and printf logs
arch/arm/dts/pcm052.dts | 2 +- arch/arm/dts/vf610-twr.dts | 2 +- common/menu.c | 2 +- drivers/ddr/fsl/lc_common_dimm_params.c | 4 ++-- 4 files changed, 5 insertions(+), 5 deletions(-)
participants (4)
-
Alexander Merkle
-
Bhuvanchandra DV
-
Bin Meng
-
Tom Rini