[U-Boot] Compilation warning: "MSR_RI" redefined

Hi Detlev,
your patch 7b5611cdd12ca0cc33f994f0d4a4454788fc3124 [inka4x0: Add hardware diagnosis functions for inka4x0] introduced all kind of new defines in the ns16550.h header resulting in a warning on some 4xx platforms:
[stefan@kubuntu u-boot (master)]$ ./MAKEALL ml300 Configuring for ml300 board... In file included from serial.c:53: /home/stefan/git/u-boot/u-boot/include/ns16550.h:151:1: warning: "MSR_RI" redefined In file included from serial.c:41: /home/stefan/git/u-boot/u-boot/include/asm/processor.h:48:1: warning: this is the location of the previous definition
I suggest to either remove this MSI_RI from the header again (it doesn't seem to be used here) or rename it.
Thanks.
Best regards, Stefan
===================================================================== DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Zundel HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany Phone: +49-8142-66989-0 Fax: +49-8142-66989-80 Email: office@denx.de =====================================================================

Hi Stefan,
your patch 7b5611cdd12ca0cc33f994f0d4a4454788fc3124 [inka4x0: Add hardware diagnosis functions for inka4x0] introduced all kind of new defines in the ns16550.h header resulting in a warning on some 4xx platforms:
[stefan@kubuntu u-boot (master)]$ ./MAKEALL ml300 Configuring for ml300 board... In file included from serial.c:53: /home/stefan/git/u-boot/u-boot/include/ns16550.h:151:1: warning: "MSR_RI" redefined In file included from serial.c:41: /home/stefan/git/u-boot/u-boot/include/asm/processor.h:48:1: warning: this is the location of the previous definition
I suggest to either remove this MSI_RI from the header again (it doesn't seem to be used here) or rename it.
Ok, so much for the plan to add the defines not bit by bit as needed, but register-wise, while we're there.
I actually would prefer to use UART_MSR_RI, as this is a UART thingy rather than to remove the define as we surely use the register, so I feel it worthwhile to have the whole definition on board.
Let me cook up a rename for the UART stuff..
Cheers Detlev

On Thursday 02 April 2009, Detlev Zundel wrote:
I suggest to either remove this MSI_RI from the header again (it doesn't seem to be used here) or rename it.
Ok, so much for the plan to add the defines not bit by bit as needed, but register-wise, while we're there.
I actually would prefer to use UART_MSR_RI, as this is a UART thingy rather than to remove the define as we surely use the register, so I feel it worthwhile to have the whole definition on board.
That's my preference as well.
Let me cook up a rename for the UART stuff..
Thanks.
Best regards, Stefan
===================================================================== DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Zundel HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany Phone: +49-8142-66989-0 Fax: +49-8142-66989-80 Email: office@denx.de =====================================================================

On Apr 2, 2009, at 4:03 AM, Stefan Roese wrote:
On Thursday 02 April 2009, Detlev Zundel wrote:
I suggest to either remove this MSI_RI from the header again (it doesn't seem to be used here) or rename it.
Ok, so much for the plan to add the defines not bit by bit as needed, but register-wise, while we're there.
I actually would prefer to use UART_MSR_RI, as this is a UART thingy rather than to remove the define as we surely use the register, so I feel it worthwhile to have the whole definition on board.
That's my preference as well.
Agreed, when I saw MSR_RI I wasn't thinking UART at all.
- k

Hi,
On Apr 2, 2009, at 4:03 AM, Stefan Roese wrote:
On Thursday 02 April 2009, Detlev Zundel wrote:
I suggest to either remove this MSI_RI from the header again (it doesn't seem to be used here) or rename it.
Ok, so much for the plan to add the defines not bit by bit as needed, but register-wise, while we're there.
I actually would prefer to use UART_MSR_RI, as this is a UART thingy rather than to remove the define as we surely use the register, so I feel it worthwhile to have the whole definition on board.
That's my preference as well.
Agreed, when I saw MSR_RI I wasn't thinking UART at all.
That's really context specific. Looking at 16550 registers for a day, I forgot the "other" meaning of MSR ;)
Attached is a patch which fixes this fallout and starts a round of cleanups.
Thanks Detlev

Dear Detlev,
In message m2r60a9ejj.fsf@ohwell.denx.de you wrote:
Attached is a patch which fixes this fallout and starts a round of cleanups.
Please submit patches inline, not as attachments!
Subject: [PATCH] Rename common ns16550 constants with UART_ prefix to prevent conflicts
Fix problems introduced in commit 7b5611cdd12ca0cc33f994f0d4a4454788fc3124 [inka4x0: Add hardware diagnosis functions for inka4x0] which redefined MSR_RI which is already used on PowerPC systems.
Also eliminate redundant definitions in ps2mult.h. More cleanup will be needed for other redundant occurrences though.
Signed-off-by: Detlev Zundel dzu@denx.de
board/inka4x0/inkadiag.c | 20 ++++---- board/linkstation/avr.c | 6 +- drivers/input/ps2ser.c | 22 ++++---- drivers/serial/ns16550.c | 39 +++++++------ include/ns16550.h | 135 +++++++++++++++++++++++++++++++-------------- include/ps2mult.h | 99 --------------------------------- 6 files changed, 139 insertions(+), 182 deletions(-)
Applied, thanks.
Best regards,
Wolfgang Denk
participants (4)
-
Detlev Zundel
-
Kumar Gala
-
Stefan Roese
-
Wolfgang Denk