[PATCH v2 0/3] riscv: Rename spl_soc_init() to spl_dram_init()

From: Lukas Funke lukas.funke@weidmueller.com
This patch series renames spl_soc_init() to spl_dram_init() since the purpose of the function is to initialization the DRAM on sifive/starfive boards. spl_dram_init() is a commonly used function for this purpose.
Changes in v2: - capitalized acronym DRAM
Lukas Funke (3): arch: riscv: Rename spl_soc_init() to spl_dram_init() board: sifive: Call spl_dram_init() for DRAM initialization board: starfive: Call spl_dram_init() for DRAM initialization
arch/riscv/cpu/fu540/spl.c | 2 +- arch/riscv/cpu/fu740/spl.c | 2 +- arch/riscv/cpu/jh7110/spl.c | 2 +- arch/riscv/include/asm/arch-fu540/spl.h | 2 +- arch/riscv/include/asm/arch-fu740/spl.h | 2 +- arch/riscv/include/asm/arch-jh7110/spl.h | 2 +- board/sifive/unleashed/spl.c | 4 ++-- board/sifive/unmatched/spl.c | 4 ++-- board/starfive/visionfive2/spl.c | 4 ++-- 9 files changed, 12 insertions(+), 12 deletions(-)

From: Lukas Funke lukas.funke@weidmueller.com
Rename spl_soc_init() to spl_dram_init() because the generic function name does not reflect what the function is actually doing. In addition spl_dram_init() is commonly used for dram initialization and should be called from board_init_f().
Signed-off-by: Lukas Funke lukas.funke@weidmueller.com ---
(no changes since v1)
arch/riscv/cpu/fu540/spl.c | 2 +- arch/riscv/cpu/fu740/spl.c | 2 +- arch/riscv/cpu/jh7110/spl.c | 2 +- arch/riscv/include/asm/arch-fu540/spl.h | 2 +- arch/riscv/include/asm/arch-fu740/spl.h | 2 +- arch/riscv/include/asm/arch-jh7110/spl.h | 2 +- 6 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/arch/riscv/cpu/fu540/spl.c b/arch/riscv/cpu/fu540/spl.c index 45657b7909..cedb70b66a 100644 --- a/arch/riscv/cpu/fu540/spl.c +++ b/arch/riscv/cpu/fu540/spl.c @@ -7,7 +7,7 @@ #include <dm.h> #include <log.h>
-int spl_soc_init(void) +int spl_dram_init(void) { int ret; struct udevice *dev; diff --git a/arch/riscv/cpu/fu740/spl.c b/arch/riscv/cpu/fu740/spl.c index c6816e9ed4..16b307f036 100644 --- a/arch/riscv/cpu/fu740/spl.c +++ b/arch/riscv/cpu/fu740/spl.c @@ -10,7 +10,7 @@
#define CSR_U74_FEATURE_DISABLE 0x7c1
-int spl_soc_init(void) +int spl_dram_init(void) { int ret; struct udevice *dev; diff --git a/arch/riscv/cpu/jh7110/spl.c b/arch/riscv/cpu/jh7110/spl.c index 6bdf8b9c72..87aaf86524 100644 --- a/arch/riscv/cpu/jh7110/spl.c +++ b/arch/riscv/cpu/jh7110/spl.c @@ -28,7 +28,7 @@ static bool check_ddr_size(phys_size_t size) } }
-int spl_soc_init(void) +int spl_dram_init(void) { int ret; struct udevice *dev; diff --git a/arch/riscv/include/asm/arch-fu540/spl.h b/arch/riscv/include/asm/arch-fu540/spl.h index 4697279f43..519e7eb210 100644 --- a/arch/riscv/include/asm/arch-fu540/spl.h +++ b/arch/riscv/include/asm/arch-fu540/spl.h @@ -9,6 +9,6 @@ #ifndef _SPL_SIFIVE_H #define _SPL_SIFIVE_H
-int spl_soc_init(void); +int spl_dram_init(void);
#endif /* _SPL_SIFIVE_H */ diff --git a/arch/riscv/include/asm/arch-fu740/spl.h b/arch/riscv/include/asm/arch-fu740/spl.h index 15ad9e7c8b..b327ac5036 100644 --- a/arch/riscv/include/asm/arch-fu740/spl.h +++ b/arch/riscv/include/asm/arch-fu740/spl.h @@ -9,6 +9,6 @@ #ifndef _SPL_SIFIVE_H #define _SPL_SIFIVE_H
-int spl_soc_init(void); +int spl_dram_init(void);
#endif /* _SPL_SIFIVE_H */ diff --git a/arch/riscv/include/asm/arch-jh7110/spl.h b/arch/riscv/include/asm/arch-jh7110/spl.h index 23ce8871b3..d73355bf35 100644 --- a/arch/riscv/include/asm/arch-jh7110/spl.h +++ b/arch/riscv/include/asm/arch-jh7110/spl.h @@ -7,6 +7,6 @@ #ifndef _SPL_STARFIVE_H #define _SPL_STARFIVE_H
-int spl_soc_init(void); +int spl_dram_init(void);
#endif /* _SPL_STARFIVE_H */

From: Lukas Funke lukas.funke@weidmueller.com
Call spl_dram_init() since this is commonly used for DRAM initialization in u-boot.
Signed-off-by: Lukas Funke lukas.funke@weidmueller.com ---
(no changes since v1)
board/sifive/unleashed/spl.c | 4 ++-- board/sifive/unmatched/spl.c | 4 ++-- 2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/board/sifive/unleashed/spl.c b/board/sifive/unleashed/spl.c index fe27316b2d..9df9c68604 100644 --- a/board/sifive/unleashed/spl.c +++ b/board/sifive/unleashed/spl.c @@ -27,9 +27,9 @@ int spl_board_init_f(void) { int ret;
- ret = spl_soc_init(); + ret = spl_dram_init(); if (ret) { - debug("FU540 SPL init failed: %d\n", ret); + debug("FU540 DRAM init failed: %d\n", ret); return ret; }
diff --git a/board/sifive/unmatched/spl.c b/board/sifive/unmatched/spl.c index e69bed9d99..6fc1d80954 100644 --- a/board/sifive/unmatched/spl.c +++ b/board/sifive/unmatched/spl.c @@ -134,9 +134,9 @@ int spl_board_init_f(void) { int ret;
- ret = spl_soc_init(); + ret = spl_dram_init(); if (ret) { - debug("HiFive Unmatched FU740 SPL init failed: %d\n", ret); + debug("HiFive Unmatched FU740 DRAM init failed: %d\n", ret); goto end; }

From: Lukas Funke lukas.funke@weidmueller.com
Call spl_dram_init() since this is commonly used for dram initialization in u-boot.
Signed-off-by: Lukas Funke lukas.funke@weidmueller.com ---
Changes in v2: - capitalized acronym DRAM
board/starfive/visionfive2/spl.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/board/starfive/visionfive2/spl.c b/board/starfive/visionfive2/spl.c index 45848db6d8..ca61b5be22 100644 --- a/board/starfive/visionfive2/spl.c +++ b/board/starfive/visionfive2/spl.c @@ -285,9 +285,9 @@ int spl_board_init_f(void)
jh7110_jtag_init();
- ret = spl_soc_init(); + ret = spl_dram_init(); if (ret) { - debug("JH7110 SPL init failed: %d\n", ret); + debug("JH7110 DRAM init failed: %d\n", ret); return ret; }

On 23.04.24 11:14, lukas.funke-oss@weidmueller.com wrote:
From: Lukas Funke lukas.funke@weidmueller.com
Call spl_dram_init() since this is commonly used for dram initialization in u-boot.
Signed-off-by: Lukas Funke lukas.funke@weidmueller.com
Changes in v2:
- capitalized acronym DRAM
board/starfive/visionfive2/spl.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/board/starfive/visionfive2/spl.c b/board/starfive/visionfive2/spl.c index 45848db6d8..ca61b5be22 100644 --- a/board/starfive/visionfive2/spl.c +++ b/board/starfive/visionfive2/spl.c @@ -285,9 +285,9 @@ int spl_board_init_f(void)
jh7110_jtag_init();
- ret = spl_soc_init();
- ret = spl_dram_init();
We want to be able to use git bisect. This requires that the source builds after each individual patch.
This change must be in the same patch in which you rename the function for the VisionFive 2.
Please, resubmit your series with two patches: one for SiFive, one for StarFive.
Best regards
Heinrich
if (ret) {
debug("JH7110 SPL init failed: %d\n", ret);
return ret; }debug("JH7110 DRAM init failed: %d\n", ret);
participants (2)
-
Heinrich Schuchardt
-
lukas.funke-oss@weidmueller.com