[U-Boot] [PATCH 0/3] remove dm_fdt_pre_reloc, replaced by dm_ofnode_pre_reloc

This Serie replace any call to dm_fdt_pre_reloc by dm_ofnode_pre_reloc and remove this function only used 2 times and avoid duplicated code.
Patches created after Simon comment on http://patchwork.ozlabs.org/patch/1052734/
bool dm_fdt_pre_reloc(const void *blob, int offset)
This function should really be removed. We should be able to use the ofnode version always.
Patrick Delaunay (3): clk: at91: replace dm_fdt_pre_reloc by dm_ofnode_pre_reloc clk: socfpga: replace dm_fdt_pre_reloc by dm_ofnode_pre_reloc dm: remove unused function dm_fdt_pre_reloc
drivers/clk/altera/clk-arria10.c | 3 ++- drivers/clk/at91/pmc.c | 2 +- drivers/core/util.c | 24 ------------------------ include/dm/util.h | 26 -------------------------- 4 files changed, 3 insertions(+), 52 deletions(-)

Prepare to remove dm_fdt_pre_reloc
Signed-off-by: Patrick Delaunay patrick.delaunay@st.com ---
drivers/clk/at91/pmc.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/clk/at91/pmc.c b/drivers/clk/at91/pmc.c index 7cfbabc..6b55ec5 100644 --- a/drivers/clk/at91/pmc.c +++ b/drivers/clk/at91/pmc.c @@ -61,7 +61,7 @@ int at91_clk_sub_device_bind(struct udevice *dev, const char *drv_name) offset > 0; offset = fdt_next_subnode(fdt, offset)) { if (pre_reloc_only && - !dm_fdt_pre_reloc(fdt, offset)) + !dm_ofnode_pre_reloc(offset_to_ofnode(offset))) continue; /* * If this node has "compatible" property, this is not

On Thu, 21 Mar 2019 at 01:22, Patrick Delaunay patrick.delaunay@st.com wrote:
Prepare to remove dm_fdt_pre_reloc
Signed-off-by: Patrick Delaunay patrick.delaunay@st.com
drivers/clk/at91/pmc.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
Reviewed-by: Simon Glass sjg@chromium.org

Prepare to remove dm_fdt_pre_reloc function.
Signed-off-by: Patrick Delaunay patrick.delaunay@st.com ---
drivers/clk/altera/clk-arria10.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/clk/altera/clk-arria10.c b/drivers/clk/altera/clk-arria10.c index 612a171..179869d 100644 --- a/drivers/clk/altera/clk-arria10.c +++ b/drivers/clk/altera/clk-arria10.c @@ -254,7 +254,8 @@ static int socfpga_a10_clk_bind(struct udevice *dev) fdt_node_check_compatible(fdt, offset, "fixed-clock")) continue;
- if (pre_reloc_only && !dm_fdt_pre_reloc(fdt, offset)) + if (pre_reloc_only && + !dm_ofnode_pre_reloc(offset_to_ofnode(offset))) continue;
ret = device_bind_driver_to_node(dev, "clk-a10", name,

On Thu, 21 Mar 2019 at 01:21, Patrick Delaunay patrick.delaunay@st.com wrote:
Prepare to remove dm_fdt_pre_reloc function.
Signed-off-by: Patrick Delaunay patrick.delaunay@st.com
drivers/clk/altera/clk-arria10.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-)
Reviewed-by: Simon Glass sjg@chromium.org

On Thu, 21 Mar 2019 at 01:21, Patrick Delaunay patrick.delaunay@st.com wrote:
Prepare to remove dm_fdt_pre_reloc function.
Signed-off-by: Patrick Delaunay patrick.delaunay@st.com
drivers/clk/altera/clk-arria10.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-)
Reviewed-by: Simon Glass sjg@chromium.org
Applied to u-boot-dm, thanks!

The function dm_ofnode_pre_reloc should be used instead of the function dm_fdt_pre_reloc and avoid duplicated code.
Signed-off-by: Patrick Delaunay patrick.delaunay@st.com ---
drivers/core/util.c | 24 ------------------------ include/dm/util.h | 26 -------------------------- 2 files changed, 50 deletions(-)
diff --git a/drivers/core/util.c b/drivers/core/util.c index 27a6848..0afdc74 100644 --- a/drivers/core/util.c +++ b/drivers/core/util.c @@ -31,30 +31,6 @@ int list_count_items(struct list_head *head) return count; }
-bool dm_fdt_pre_reloc(const void *blob, int offset) -{ - if (fdt_getprop(blob, offset, "u-boot,dm-pre-reloc", NULL)) - return true; - -#ifdef CONFIG_TPL_BUILD - if (fdt_getprop(blob, offset, "u-boot,dm-tpl", NULL)) - return true; -#elif defined(CONFIG_SPL_BUILD) - if (fdt_getprop(blob, offset, "u-boot,dm-spl", NULL)) - return true; -#else - /* - * In regular builds individual spl and tpl handling both - * count as handled pre-relocation for later second init. - */ - if (fdt_getprop(blob, offset, "u-boot,dm-spl", NULL) || - fdt_getprop(blob, offset, "u-boot,dm-tpl", NULL)) - return true; -#endif - - return false; -} - bool dm_ofnode_pre_reloc(ofnode node) { if (ofnode_read_bool(node, "u-boot,dm-pre-reloc")) diff --git a/include/dm/util.h b/include/dm/util.h index 9ff6531..60d3b93 100644 --- a/include/dm/util.h +++ b/include/dm/util.h @@ -40,32 +40,6 @@ static inline void dm_dump_devres(void) #endif
/** - * Check if a dt node should be or was bound before relocation. - * - * Devicetree nodes can be marked as needed to be bound - * in the loader stages via special devicetree properties. - * - * Before relocation this function can be used to check if nodes - * are required in either SPL or TPL stages. - * - * After relocation and jumping into the real U-Boot binary - * it is possible to determine if a node was bound in one of - * SPL/TPL stages. - * - * There are 3 settings currently in use - * - - * - u-boot,dm-pre-reloc: legacy and indicates any of TPL or SPL - * Existing platforms only use it to indicate nodes needed in - * SPL. Should probably be replaced by u-boot,dm-spl for - * existing platforms. - * @blob: devicetree - * @offset: node offset - * - * Returns true if node is needed in SPL/TL, false otherwise. - */ -bool dm_fdt_pre_reloc(const void *blob, int offset); - -/** * Check if an of node should be or was bound before relocation. * * Devicetree nodes can be marked as needed to be bound

On Thu, 21 Mar 2019 at 01:21, Patrick Delaunay patrick.delaunay@st.com wrote:
The function dm_ofnode_pre_reloc should be used instead of the function dm_fdt_pre_reloc and avoid duplicated code.
Signed-off-by: Patrick Delaunay patrick.delaunay@st.com
drivers/core/util.c | 24 ------------------------ include/dm/util.h | 26 -------------------------- 2 files changed, 50 deletions(-)
Reviewed-by: Simon Glass sjg@chromium.org
Thanks.

On Thu, 21 Mar 2019 at 01:21, Patrick Delaunay patrick.delaunay@st.com wrote:
The function dm_ofnode_pre_reloc should be used instead of the function dm_fdt_pre_reloc and avoid duplicated code.
Signed-off-by: Patrick Delaunay patrick.delaunay@st.com
drivers/core/util.c | 24 ------------------------ include/dm/util.h | 26 -------------------------- 2 files changed, 50 deletions(-)
Reviewed-by: Simon Glass sjg@chromium.org
Thanks.
Applied to u-boot-dm, thanks!
participants (3)
-
Patrick Delaunay
-
Simon Glass
-
sjg@google.com