[U-Boot] [PATCH] [v4] powerpc: clean up DIU macro definitions for Freescale reference boards

Clean up the macro defintions used to enable DIU (video) support on the MPC8610HPCD and the MPC5121ADS so that they look more like the P1022DS, which is newer. Add software cursor support to all three boards.
Also document the CONFIG_FSL_DIU_FB in the README.
Signed-off-by: Timur Tabi timur@freescale.com --- README | 22 ++++++++++++++++++++++ include/configs/MPC8610HPCD.h | 13 ++++--------- include/configs/P1022DS.h | 3 +-- include/configs/mpc5121ads.h | 9 ++++----- 4 files changed, 31 insertions(+), 16 deletions(-)
diff --git a/README b/README index 755d17c..9597fed 100644 --- a/README +++ b/README @@ -1057,6 +1057,28 @@ The following options need to be configured: and 16bpp modes defined by CONFIG_VIDEO_SED13806_8BPP or CONFIG_VIDEO_SED13806_16BPP
+ CONFIG_FSL_DIU_FB + Enable the Freescale DIU video driver. Reference boards for + SOCs that have a DIU should define this macro to enable DIU + support, and should also define these other macros: + + CONFIG_SYS_DIU_ADDR + CONFIG_VIDEO + CONFIG_CMD_BMP + CONFIG_CFB_CONSOLE + CONFIG_VIDEO_SW_CURSOR + CONFIG_VGA_AS_SINGLE_DEVICE + CONFIG_VIDEO_LOGO + CONFIG_VIDEO_BMP_LOGO + + The DIU driver will look for the 'monitor' environment variable, + and if defined, enable the DIU as a console during boot. This + variable should be set to one of these values: + + '0' Output video to the DVI connector + '1' Output video to the LVDS connector + '2' Output video to the Dual-Link LVDS connector + - Keyboard Support: CONFIG_KEYBOARD
diff --git a/include/configs/MPC8610HPCD.h b/include/configs/MPC8610HPCD.h index 03ee394..de01c31 100644 --- a/include/configs/MPC8610HPCD.h +++ b/include/configs/MPC8610HPCD.h @@ -21,14 +21,14 @@
#define CONFIG_SYS_TEXT_BASE 0xfff00000
-#define CONFIG_FSL_DIU_FB 1 /* FSL DIU */
/* video */ -#undef CONFIG_VIDEO - -#ifdef CONFIG_VIDEO +#ifdef CONFIG_FSL_DIU_FB +#define CONFIG_SYS_DIU_ADDR (CONFIG_SYS_CCSRBAR + 0x2c000) +#define CONFIG_VIDEO #define CONFIG_CMD_BMP #define CONFIG_CFB_CONSOLE +#define CONFIG_VIDEO_SW_CURSOR #define CONFIG_VGA_AS_SINGLE_DEVICE #define CONFIG_VIDEO_LOGO #define CONFIG_VIDEO_BMP_LOGO @@ -88,8 +88,6 @@ #define CONFIG_SYS_CCSRBAR_PHYS_HIGH 0x0 #define CONFIG_SYS_CCSRBAR_PHYS CONFIG_SYS_CCSRBAR_PHYS_LOW
-#define CONFIG_SYS_DIU_ADDR (CONFIG_SYS_CCSRBAR+0x2c000) - /* DDR Setup */ #define CONFIG_FSL_DDR2 #undef CONFIG_FSL_DDR_INTERACTIVE @@ -494,9 +492,6 @@ #define CONFIG_WATCHDOG /* watchdog enabled */ #define CONFIG_SYS_WATCHDOG_FREQ 5000 /* Feed interval, 5s */
-/*DIU Configuration*/ -#define DIU_CONNECT_TO_DVI /* DIU controller connects to DVI encoder*/ - /* * Miscellaneous configurable options */ diff --git a/include/configs/P1022DS.h b/include/configs/P1022DS.h index cb24041..ed2bada 100644 --- a/include/configs/P1022DS.h +++ b/include/configs/P1022DS.h @@ -185,13 +185,12 @@ #define CONFIG_SYS_PROMPT_HUSH_PS2 "> "
/* Video */ -#undef CONFIG_FSL_DIU_FB - #ifdef CONFIG_FSL_DIU_FB #define CONFIG_SYS_DIU_ADDR (CONFIG_SYS_CCSRBAR + 0x10000) #define CONFIG_VIDEO #define CONFIG_CMD_BMP #define CONFIG_CFB_CONSOLE +#define CONFIG_VIDEO_SW_CURSOR #define CONFIG_VGA_AS_SINGLE_DEVICE #define CONFIG_VIDEO_LOGO #define CONFIG_VIDEO_BMP_LOGO diff --git a/include/configs/mpc5121ads.h b/include/configs/mpc5121ads.h index f966325..e7ef298 100644 --- a/include/configs/mpc5121ads.h +++ b/include/configs/mpc5121ads.h @@ -46,16 +46,16 @@ */ #define CONFIG_E300 1 /* E300 Family */ #define CONFIG_MPC512X 1 /* MPC512X family */ -#define CONFIG_FSL_DIU_FB 1 /* FSL DIU */
#define CONFIG_SYS_TEXT_BASE 0xFFF00000
/* video */ -#undef CONFIG_VIDEO - -#ifdef CONFIG_VIDEO +#ifdef CONFIG_FSL_DIU_FB +#define CONFIG_SYS_DIU_ADDR (CONFIG_SYS_IMMR + 0x2100) +#define CONFIG_VIDEO #define CONFIG_CMD_BMP #define CONFIG_CFB_CONSOLE +#define CONFIG_VIDEO_SW_CURSOR #define CONFIG_VGA_AS_SINGLE_DEVICE #define CONFIG_VIDEO_LOGO #define CONFIG_VIDEO_BMP_LOGO @@ -74,7 +74,6 @@ #define CONFIG_MISC_INIT_R
#define CONFIG_SYS_IMMR 0x80000000 -#define CONFIG_SYS_DIU_ADDR (CONFIG_SYS_IMMR+0x2100)
#define CONFIG_SYS_MEMTEST_START 0x00200000 /* memtest region */ #define CONFIG_SYS_MEMTEST_END 0x00400000

Timur Tabi wrote:
Clean up the macro defintions used to enable DIU (video) support on the MPC8610HPCD and the MPC5121ADS so that they look more like the P1022DS, which is newer. Add software cursor support to all three boards.
Also document the CONFIG_FSL_DIU_FB in the README.
Signed-off-by: Timur Tabi timur@freescale.com
Wolfgang,
If you're okay with this patch, could you ACK it so that Kumar can queue it for -next?

On Feb 18, 2011, at 2:51 PM, Timur Tabi wrote:
Timur Tabi wrote:
Clean up the macro defintions used to enable DIU (video) support on the MPC8610HPCD and the MPC5121ADS so that they look more like the P1022DS, which is newer. Add software cursor support to all three boards.
Also document the CONFIG_FSL_DIU_FB in the README.
Signed-off-by: Timur Tabi timur@freescale.com
Wolfgang,
If you're okay with this patch, could you ACK it so that Kumar can queue it for -next?
Wolfgang,
Please ACK based on previous comments.
- k

Dear Kumar Gala,
In message 95D0C1D3-192C-49E1-932C-E757F199835C@freescale.com you wrote:
Clean up the macro defintions used to enable DIU (video) support on the MPC8610HPCD and the MPC5121ADS so that they look more like the P1022DS, which is newer. Add software cursor support to all three boards.
Also document the CONFIG_FSL_DIU_FB in the README.
Signed-off-by: Timur Tabi timur@freescale.com
Wolfgang,
If you're okay with this patch, could you ACK it so that Kumar can > queue it for -next?
Wolfgang,
Please ACK based on previous comments.
Why me?
Video stuff is obviously something the video custodian should handle.
Of course, this would require that Timur puts the responsible custodian on Cc: ...
Best regards,
Wolfgang Denk

Wolfgang Denk wrote:
Video stuff is obviously something the video custodian should handle.
Of course, this would require that Timur puts the responsible custodian on Cc: ...
I personally don't see how the video maintainer needs to get involved, since I'm just changing a few macros in board header files. That's why the patch is labeled "powerpc:" and not "video:".

Dear Timur Tabi,
In message 4D9A156F.8050303@freescale.com you wrote:
I personally don't see how the video maintainer needs to get involved, since I'm just changing a few macros in board header files. That's why the patch is labeled "powerpc:" and not "video:".
The fact that you label something A does not mean that it should acutally be B instead.
You know my position. I want to see at least Anatolij's ACK on this.
Best regards,
Wolfgang Denk

On Apr 4, 2011, at 1:57 PM, Wolfgang Denk wrote:
Dear Kumar Gala,
In message 95D0C1D3-192C-49E1-932C-E757F199835C@freescale.com you wrote:
Clean up the macro defintions used to enable DIU (video) support on the MPC8610HPCD and the MPC5121ADS so that they look more like the P1022DS, which is newer. Add software cursor support to all three boards.
Also document the CONFIG_FSL_DIU_FB in the README.
Signed-off-by: Timur Tabi timur@freescale.com
Wolfgang,
If you're okay with this patch, could you ACK it so that Kumar can > queue it for -next?
Wolfgang,
Please ACK based on previous comments.
Why me?
I was only looking for ACK because of your feedback on the patch. I like to assume any case that has significant feedback its reasonable for the main feedback giver to ack at some point.
- k

Dear Kumar Gala,
In message D6498B0E-A435-43B5-8422-BDB23E88C947@freescale.com you wrote:
Please ACK based on previous comments.
Why me?
I was only looking for ACK because of your feedback on the patch. I like to assume any case that has significant feedback its reasonable for the main feedback giver to ack at some point.
I see. But the really missing ACK is Anatolij's.
Best regards,
Wolfgang Denk

On Tue, 15 Feb 2011 17:09:19 -0600 Timur Tabi timur@freescale.com wrote:
Clean up the macro defintions used to enable DIU (video) support on the MPC8610HPCD and the MPC5121ADS so that they look more like the P1022DS, which is newer. Add software cursor support to all three boards.
Also document the CONFIG_FSL_DIU_FB in the README.
Signed-off-by: Timur Tabi timur@freescale.com
README | 22 ++++++++++++++++++++++ include/configs/MPC8610HPCD.h | 13 ++++--------- include/configs/P1022DS.h | 3 +-- include/configs/mpc5121ads.h | 9 ++++----- 4 files changed, 31 insertions(+), 16 deletions(-)
Acked-by: Anatolij Gustschin agust@denx.de

On Feb 15, 2011, at 5:09 PM, Timur Tabi wrote:
Clean up the macro defintions used to enable DIU (video) support on the MPC8610HPCD and the MPC5121ADS so that they look more like the P1022DS, which is newer. Add software cursor support to all three boards.
Also document the CONFIG_FSL_DIU_FB in the README.
Signed-off-by: Timur Tabi timur@freescale.com
README | 22 ++++++++++++++++++++++ include/configs/MPC8610HPCD.h | 13 ++++--------- include/configs/P1022DS.h | 3 +-- include/configs/mpc5121ads.h | 9 ++++----- 4 files changed, 31 insertions(+), 16 deletions(-)
applied to 85xx
- k

Dear Timur Tabi,
In message 1297811359-28389-1-git-send-email-timur@freescale.com you wrote:
Clean up the macro defintions used to enable DIU (video) support on the MPC8610HPCD and the MPC5121ADS so that they look more like the P1022DS, which is newer. Add software cursor support to all three boards.
Software cursor support should be split off into a separate patch. And CONFIG_VIDEO_SW_CURSOR needs to be documented.
Also document the CONFIG_FSL_DIU_FB in the README.
...
The DIU driver will look for the 'monitor' environment variable,
and if defined, enable the DIU as a console during boot. This
variable should be set to one of these values:
'0' Output video to the DVI connector
'1' Output video to the LVDS connector
'2' Output video to the Dual-Link LVDS connector
Maybe it would be more user-friendly if we used easy to remember names instead of some magic numbers, like "dvi", "lvds" resp. "dlvds" (or whatever) ?
Best regards,
Wolfgang Denk

Wolfgang Denk wrote:
Software cursor support should be split off into a separate patch. And CONFIG_VIDEO_SW_CURSOR needs to be documented.
That feature is already in U-Boot. All I'm doing is adding a #define CONFIG_VIDEO_SW_CURSOR to the header file. I thought it was already documented somewhere.
'0' Output video to the DVI connector
'1' Output video to the LVDS connector
'2' Output video to the Dual-Link LVDS connector
Maybe it would be more user-friendly if we used easy to remember names instead of some magic numbers, like "dvi", "lvds" resp. "dlvds" (or whatever) ?
That's already fixed in my follow-up patch that is waiting for Anatolij's ACK.
participants (5)
-
Anatolij Gustschin
-
Kumar Gala
-
Tabi Timur-B04825
-
Timur Tabi
-
Wolfgang Denk