[RFC PATCH] Rename disto_[pxe_]getfile to distro_[pxe_]getfile

Replace 'disto' with 'distro' since they are all functions about distro booting.
Signed-off-by: Dario Binacchi dario.binacchi@amarulasolutions.com
---
boot/bootmeth_distro.c | 6 +++--- boot/bootmeth_pxe.c | 6 +++--- doc/develop/bootstd.rst | 2 +- 3 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/boot/bootmeth_distro.c b/boot/bootmeth_distro.c index fea09b2c2fbe..5c6c687f0a64 100644 --- a/boot/bootmeth_distro.c +++ b/boot/bootmeth_distro.c @@ -35,8 +35,8 @@ static int distro_get_state_desc(struct udevice *dev, char *buf, int maxsize) return 0; }
-static int disto_getfile(struct pxe_context *ctx, const char *file_path, - char *file_addr, ulong *sizep) +static int distro_getfile(struct pxe_context *ctx, const char *file_path, + char *file_addr, ulong *sizep) { struct distro_info *info = ctx->userdata; ulong addr; @@ -113,7 +113,7 @@ static int distro_boot(struct udevice *dev, struct bootflow *bflow) addr = map_to_sysmem(bflow->buf); info.dev = dev; info.bflow = bflow; - ret = pxe_setup_ctx(&ctx, &cmdtp, disto_getfile, &info, true, + ret = pxe_setup_ctx(&ctx, &cmdtp, distro_getfile, &info, true, bflow->subdir); if (ret) return log_msg_ret("ctx", -EINVAL); diff --git a/boot/bootmeth_pxe.c b/boot/bootmeth_pxe.c index f1e2b4c77627..e6992168c067 100644 --- a/boot/bootmeth_pxe.c +++ b/boot/bootmeth_pxe.c @@ -23,8 +23,8 @@ #include <net.h> #include <pxe_utils.h>
-static int disto_pxe_getfile(struct pxe_context *ctx, const char *file_path, - char *file_addr, ulong *sizep) +static int distro_pxe_getfile(struct pxe_context *ctx, const char *file_path, + char *file_addr, ulong *sizep) { struct distro_info *info = ctx->userdata; ulong addr; @@ -142,7 +142,7 @@ static int distro_pxe_boot(struct udevice *dev, struct bootflow *bflow) info.dev = dev; info.bflow = bflow; info.cmdtp = &cmdtp; - ret = pxe_setup_ctx(ctx, &cmdtp, disto_pxe_getfile, &info, false, + ret = pxe_setup_ctx(ctx, &cmdtp, distro_pxe_getfile, &info, false, bflow->subdir); if (ret) return log_msg_ret("ctx", -EINVAL); diff --git a/doc/develop/bootstd.rst b/doc/develop/bootstd.rst index f7fc72570766..1ccc49424ebd 100644 --- a/doc/develop/bootstd.rst +++ b/doc/develop/bootstd.rst @@ -322,7 +322,7 @@ look like this::
The `sf-bootdev` driver can implement a way to read from the SPI flash, using the offset and size provided, and return that bootflow file back to the caller. -When distro boot wants to read the kernel it calls disto_getfile() which must +When distro boot wants to read the kernel it calls distro_getfile() which must provide a way to read from the SPI flash. See `distro_boot()` at distro_boot_ for more details.

On Fri, 26 Aug 2022 at 07:15, Dario Binacchi dario.binacchi@amarulasolutions.com wrote:
Replace 'disto' with 'distro' since they are all functions about distro booting.
Signed-off-by: Dario Binacchi dario.binacchi@amarulasolutions.com
boot/bootmeth_distro.c | 6 +++--- boot/bootmeth_pxe.c | 6 +++--- doc/develop/bootstd.rst | 2 +- 3 files changed, 7 insertions(+), 7 deletions(-)
Reviewed-by: Simon Glass sjg@chromium.org

On Fri, 26 Aug 2022 at 18:21, Simon Glass sjg@chromium.org wrote:
On Fri, 26 Aug 2022 at 07:15, Dario Binacchi dario.binacchi@amarulasolutions.com wrote:
Replace 'disto' with 'distro' since they are all functions about distro booting.
Signed-off-by: Dario Binacchi dario.binacchi@amarulasolutions.com
boot/bootmeth_distro.c | 6 +++--- boot/bootmeth_pxe.c | 6 +++--- doc/develop/bootstd.rst | 2 +- 3 files changed, 7 insertions(+), 7 deletions(-)
Reviewed-by: Simon Glass sjg@chromium.org
Applied to u-boot-dm, thanks!
participants (2)
-
Dario Binacchi
-
Simon Glass