[PATCH 0/2] Fix remained SPL_MMC_SUPPORT options

SPL_MMC_SUPPORT option is still used in few places in spite of renaming in the commit 103c5f18069 ("mmc: Rename MMC_SUPPORT to MMC"). This patch set fixes the rest of SPL_MMC_SUPPORT options.
Oleksandr Suvorov (2): mx7ulp_com: fix obsolete option SPL_MMC_SUPPORT arm: imx8m: imx8mp_rsb3720a1: fix name of option SPL_MMC_SUPPORT
arch/arm/mach-imx/mx7ulp/Kconfig | 2 +- board/advantech/imx8mp_rsb3720a1/imx8mp_rsb3720a1.c | 4 ++-- 2 files changed, 3 insertions(+), 3 deletions(-)

SPL_MMC_SUPPORT is renamed to SPL_MMC in the commit 103c5f18069 ("mmc: Rename MMC_SUPPORT to MMC")
Fix the name of that option used in TARGET_MX7ULP_COM.
Fixes: 8b71576f384 ("mx7ulp_com: add support for SPL") Signed-off-by: Oleksandr Suvorov oleksandr.suvorov@foundries.io ---
arch/arm/mach-imx/mx7ulp/Kconfig | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/mach-imx/mx7ulp/Kconfig b/arch/arm/mach-imx/mx7ulp/Kconfig index 615d75bdd0b..561ca22a764 100644 --- a/arch/arm/mach-imx/mx7ulp/Kconfig +++ b/arch/arm/mach-imx/mx7ulp/Kconfig @@ -28,7 +28,7 @@ config TARGET_MX7ULP_COM select SPL_LIBCOMMON_SUPPORT if SPL select SPL_LIBDISK_SUPPORT if SPL select SPL_LIBGENERIC_SUPPORT if SPL - select SPL_MMC_SUPPORT if SPL + select SPL_MMC if SPL select SPL_OF_CONTROL if SPL select SPL_OF_LIBFDT if SPL select SPL_PINCTRL if SPL

SPL_MMC_SUPPORT is renamed to SPL_MMC in the commit 103c5f18069 ("mmc: Rename MMC_SUPPORT to MMC")
Fix the name of the option used in TARGET_MX7ULP_COM.
Fixes: ddb56f371a7 ("arm: imx8m: add support for Advantech RSB-3720") Signed-off-by: Oleksandr Suvorov oleksandr.suvorov@foundries.io ---
board/advantech/imx8mp_rsb3720a1/imx8mp_rsb3720a1.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/board/advantech/imx8mp_rsb3720a1/imx8mp_rsb3720a1.c b/board/advantech/imx8mp_rsb3720a1/imx8mp_rsb3720a1.c index 0a1b2c94161..aa9687f7a9d 100644 --- a/board/advantech/imx8mp_rsb3720a1/imx8mp_rsb3720a1.c +++ b/board/advantech/imx8mp_rsb3720a1/imx8mp_rsb3720a1.c @@ -206,7 +206,7 @@ int board_late_init(void) return 0; }
-#ifdef CONFIG_SPL_MMC_SUPPORT +#ifdef CONFIG_SPL_MMC #define UBOOT_RAW_SECTOR_OFFSET 0x40 unsigned long spl_mmc_get_uboot_raw_sector(struct mmc *mmc) { @@ -219,4 +219,4 @@ unsigned long spl_mmc_get_uboot_raw_sector(struct mmc *mmc) return CONFIG_SYS_MMCSD_RAW_MODE_U_BOOT_SECTOR; } } -#endif /* CONFIG_SPL_MMC_SUPPORT */ +#endif /* CONFIG_SPL_MMC */

Please, ignore this patchset - these issues were fixed in another one just applied.
On Thu, Aug 4, 2022 at 9:16 PM Oleksandr Suvorov oleksandr.suvorov@foundries.io wrote:
SPL_MMC_SUPPORT option is still used in few places in spite of renaming in the commit 103c5f18069 ("mmc: Rename MMC_SUPPORT to MMC"). This patch set fixes the rest of SPL_MMC_SUPPORT options.
Oleksandr Suvorov (2): mx7ulp_com: fix obsolete option SPL_MMC_SUPPORT arm: imx8m: imx8mp_rsb3720a1: fix name of option SPL_MMC_SUPPORT
arch/arm/mach-imx/mx7ulp/Kconfig | 2 +- board/advantech/imx8mp_rsb3720a1/imx8mp_rsb3720a1.c | 4 ++-- 2 files changed, 3 insertions(+), 3 deletions(-)
-- 2.37.1

On 05.08.22 09:42, Oleksandr Suvorov wrote:
Please, ignore this patchset - these issues were fixed in another one just applied.
Got it, thanks.
Regards, Stefano
On Thu, Aug 4, 2022 at 9:16 PM Oleksandr Suvorov oleksandr.suvorov@foundries.io wrote:
SPL_MMC_SUPPORT option is still used in few places in spite of renaming in the commit 103c5f18069 ("mmc: Rename MMC_SUPPORT to MMC"). This patch set fixes the rest of SPL_MMC_SUPPORT options.
Oleksandr Suvorov (2): mx7ulp_com: fix obsolete option SPL_MMC_SUPPORT arm: imx8m: imx8mp_rsb3720a1: fix name of option SPL_MMC_SUPPORT
arch/arm/mach-imx/mx7ulp/Kconfig | 2 +- board/advantech/imx8mp_rsb3720a1/imx8mp_rsb3720a1.c | 4 ++-- 2 files changed, 3 insertions(+), 3 deletions(-)
-- 2.37.1
participants (3)
-
Oleksandr Suvorov
-
Oleksandr Suvorov
-
Stefano Babic