[U-Boot] [PATCH v2 0/8] spl: Move image loader names into the linker list

At present we have a linker list for all the image-loader methods but announce_boot_device() uses its own switch() statement with the names of each method. We may as well combine the name into the linker list.
The names are only needed if libcommon support is enabled, since printf() is used to display then.
This series performs this adjustment, by adding the names and then converting the generic SPL code over to use them. This allows the board-specific spl_board_announce_boot_device() functions to be dropped as well.
Changes in v2: - Drop incorrect use of ARRAY_SIZE in boot_from_devices() - Add a function comment to boot_from_devices()
Simon Glass (8): spl: Use a single underscore in the SPL_LOAD_IMAGE_METHOD() macro spl: Add a name to the SPL load-image methods spl: Move the loading code into its own function spl: Pass the loader into spl_load_image() spl: Drop announce_boot_device() spl: sunxi: Drop spl_board_announce_boot_device() spl: uniphier: Drop spl_board_announce_boot_device() spl: sandbox: Drop spl_board_announce_boot_device()
arch/arm/mach-sunxi/board.c | 11 +-- arch/arm/mach-uniphier/boot-mode/spl_board.c | 7 +- arch/sandbox/cpu/spl.c | 19 +--- common/spl/spl.c | 133 +++++++-------------------- common/spl/spl_mmc.c | 6 +- common/spl/spl_nand.c | 2 +- common/spl/spl_net.c | 5 +- common/spl/spl_nor.c | 2 +- common/spl/spl_onenand.c | 3 +- common/spl/spl_sata.c | 2 +- common/spl/spl_spi.c | 2 +- common/spl/spl_ubi.c | 4 +- common/spl/spl_usb.c | 2 +- common/spl/spl_ymodem.c | 2 +- drivers/mtd/spi/sunxi_spi_spl.c | 2 +- include/spl.h | 27 ++++-- 16 files changed, 78 insertions(+), 151 deletions(-)
participants (1)
-
Simon Glass