[U-Boot] [PATCH 27/31] 8xx, mgsuvd: rename board to a more generic name

renaming the "mgsuvd" board port into "km8xx", because there will come more similar boards from keymile. Compiling the mgsuvd board with "make mgsuvd_config" remains.
Signed-off-by: Heiko Schocher hs@denx.de --- Makefile | 8 ++++++-- board/keymile/{mgsuvd => km8xx}/Makefile | 2 +- board/keymile/{mgsuvd => km8xx}/config.mk | 0 board/keymile/{mgsuvd/mgsuvd.c => km8xx/km8xx.c} | 0 .../mgsuvd_hdlc_enet.c => km8xx/km8xx_hdlc_enet.c} | 0 board/keymile/{mgsuvd => km8xx}/u-boot.lds | 0 include/configs/{mgsuvd.h => km8xx.h} | 1 - 7 files changed, 7 insertions(+), 4 deletions(-) rename board/keymile/{mgsuvd => km8xx}/Makefile (98%) rename board/keymile/{mgsuvd => km8xx}/config.mk (100%) rename board/keymile/{mgsuvd/mgsuvd.c => km8xx/km8xx.c} (100%) rename board/keymile/{mgsuvd/mgsuvd_hdlc_enet.c => km8xx/km8xx_hdlc_enet.c} (100%) rename board/keymile/{mgsuvd => km8xx}/u-boot.lds (100%) rename include/configs/{mgsuvd.h => km8xx.h} (99%)
diff --git a/Makefile b/Makefile index 8c73586..70d60b5 100644 --- a/Makefile +++ b/Makefile @@ -938,8 +938,12 @@ MBX860T_config: unconfig @$(MKCONFIG) $(@:_config=) ppc mpc8xx mbx8xx
mgsuvd_config: unconfig - @$(MKCONFIG) $(@:_config=) ppc mpc8xx mgsuvd keymile - + @mkdir -p $(obj)include + @{ echo "#define CONFIG_MGSUVD" >>$(obj)include/config.h ; \ + $(XECHO) "mgsuvd configuration" ; \ + } + @$(MKCONFIG) -a km8xx ppc mpc8xx km8xx keymile + MHPC_config: unconfig @$(MKCONFIG) $(@:_config=) ppc mpc8xx mhpc eltec
diff --git a/board/keymile/mgsuvd/Makefile b/board/keymile/km8xx/Makefile similarity index 98% rename from board/keymile/mgsuvd/Makefile rename to board/keymile/km8xx/Makefile index 2c5732d..a6f3241 100644 --- a/board/keymile/mgsuvd/Makefile +++ b/board/keymile/km8xx/Makefile @@ -29,7 +29,7 @@ endif LIB = $(obj)lib$(BOARD).a
COBJS = $(BOARD).o ../common/common.o ../common/keymile_hdlc_enet.o \ - mgsuvd_hdlc_enet.o + km8xx_hdlc_enet.o
SRCS := $(SOBJS:.o=.S) $(COBJS:.o=.c) OBJS := $(addprefix $(obj),$(COBJS)) diff --git a/board/keymile/mgsuvd/config.mk b/board/keymile/km8xx/config.mk similarity index 100% rename from board/keymile/mgsuvd/config.mk rename to board/keymile/km8xx/config.mk diff --git a/board/keymile/mgsuvd/mgsuvd.c b/board/keymile/km8xx/km8xx.c similarity index 100% rename from board/keymile/mgsuvd/mgsuvd.c rename to board/keymile/km8xx/km8xx.c diff --git a/board/keymile/mgsuvd/mgsuvd_hdlc_enet.c b/board/keymile/km8xx/km8xx_hdlc_enet.c similarity index 100% rename from board/keymile/mgsuvd/mgsuvd_hdlc_enet.c rename to board/keymile/km8xx/km8xx_hdlc_enet.c diff --git a/board/keymile/mgsuvd/u-boot.lds b/board/keymile/km8xx/u-boot.lds similarity index 100% rename from board/keymile/mgsuvd/u-boot.lds rename to board/keymile/km8xx/u-boot.lds diff --git a/include/configs/mgsuvd.h b/include/configs/km8xx.h similarity index 99% rename from include/configs/mgsuvd.h rename to include/configs/km8xx.h index 66bcc73..9088d6a 100644 --- a/include/configs/mgsuvd.h +++ b/include/configs/km8xx.h @@ -34,7 +34,6 @@ */
#define CONFIG_MPC866 1 /* This is a MPC866 CPU */ -#define CONFIG_MGSUVD 1 /* ...on a mgsuvd board */ #define CONFIG_HOSTNAME mgsuvd
/* include common defines/options for all Keymile boards */

Dear Heiko Schocher,
In message 4980281E.2040504@denx.de you wrote:
renaming the "mgsuvd" board port into "km8xx", because there will come more similar boards from keymile. Compiling the mgsuvd board with "make mgsuvd_config" remains.
Signed-off-by: Heiko Schocher hs@denx.de
Makefile | 8 ++++++-- board/keymile/{mgsuvd => km8xx}/Makefile | 2 +- board/keymile/{mgsuvd => km8xx}/config.mk | 0 board/keymile/{mgsuvd/mgsuvd.c => km8xx/km8xx.c} | 0 .../mgsuvd_hdlc_enet.c => km8xx/km8xx_hdlc_enet.c} | 0 board/keymile/{mgsuvd => km8xx}/u-boot.lds | 0 include/configs/{mgsuvd.h => km8xx.h} | 1 - 7 files changed, 7 insertions(+), 4 deletions(-) rename board/keymile/{mgsuvd => km8xx}/Makefile (98%) rename board/keymile/{mgsuvd => km8xx}/config.mk (100%) rename board/keymile/{mgsuvd/mgsuvd.c => km8xx/km8xx.c} (100%) rename board/keymile/{mgsuvd/mgsuvd_hdlc_enet.c => km8xx/km8xx_hdlc_enet.c} (100%) rename board/keymile/{mgsuvd => km8xx}/u-boot.lds (100%) rename include/configs/{mgsuvd.h => km8xx.h} (99%)
diff --git a/Makefile b/Makefile index 8c73586..70d60b5 100644 --- a/Makefile +++ b/Makefile @@ -938,8 +938,12 @@ MBX860T_config: unconfig @$(MKCONFIG) $(@:_config=) ppc mpc8xx mbx8xx
mgsuvd_config: unconfig
- @$(MKCONFIG) $(@:_config=) ppc mpc8xx mgsuvd keymile
- @mkdir -p $(obj)include
- @{ echo "#define CONFIG_MGSUVD" >>$(obj)include/config.h ; \
$(XECHO) "mgsuvd configuration" ; \
}
- @$(MKCONFIG) -a km8xx ppc mpc8xx km8xx keymile
You don't intend to add more such long Makefile entries then, when more such boards are coming, or do you?
Please keep the Makefile as small as possible - I don't like so see one line of text exploding into 5 - and this for N boards.
Best regards,
Wolfgang Denk
participants (2)
-
Heiko Schocher
-
Wolfgang Denk