[U-Boot] [PATCH] net: pch_gbe: Fix pch_gbe device name

15 Apr
2015
15 Apr
'15
5:18 a.m.
The name "pch_gbe.%x" exceeds the limit of the name in the 'struct eth_device'. Rename it as just "pch_gbe".
Signed-off-by: Bin Meng bmeng.cn@gmail.com ---
drivers/net/pch_gbe.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/net/pch_gbe.c b/drivers/net/pch_gbe.c index 976848d..6c7b551 100644 --- a/drivers/net/pch_gbe.c +++ b/drivers/net/pch_gbe.c @@ -446,7 +446,7 @@ int pch_gbe_register(bd_t *bis) dev->iobase = iobase; priv->mac_regs = (struct pch_gbe_regs *)iobase;
- sprintf(dev->name, "pch_gbe.%x", iobase); + sprintf(dev->name, "pch_gbe");
/* Read MAC address from SROM and initialize dev->enetaddr with it */ pch_gbe_mac_read(priv->mac_regs, dev->enetaddr);
--
1.8.2.1
3677
Age (days ago)
3677
Last active (days ago)
0 comments
1 participants
participants (1)
-
Bin Meng