[U-Boot] [PATCH 1/3] Kconfig: disambiguate config names for tiny printf

27084c03d36a ("spl: Allow tiny printf() to be controlled in SPL and TPL") split this option in two for TPL and SPL, but didn't change the Kconfig names, making them hard to set quickly.
Signed-off-by: Thomas Hebb tommyhebb@gmail.com --- lib/Kconfig | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/lib/Kconfig b/lib/Kconfig index b8a8509d72..55dedcbcdd 100644 --- a/lib/Kconfig +++ b/lib/Kconfig @@ -96,7 +96,7 @@ config SYS_HZ set to 1000.
config SPL_USE_TINY_PRINTF - bool "Enable tiny printf() version" + bool "Enable tiny printf() version in SPL" depends on SPL default y help @@ -108,7 +108,7 @@ config SPL_USE_TINY_PRINTF The supported format specifiers are %c, %s, %u/%d and %x.
config TPL_USE_TINY_PRINTF - bool "Enable tiny printf() version" + bool "Enable tiny printf() version in TPL" depends on TPL default y if SPL_USE_TINY_PRINTF help

SPL_ROCKCHIP_COMMON_BOARD, an almost identical option, has a title but this one doesn't for some reason. Add a description to make the menu easier to read.
Signed-off-by: Thomas Hebb tommyhebb@gmail.com --- arch/arm/mach-rockchip/Kconfig | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/mach-rockchip/Kconfig b/arch/arm/mach-rockchip/Kconfig index f5a80b4f0c..5e5f910b9a 100644 --- a/arch/arm/mach-rockchip/Kconfig +++ b/arch/arm/mach-rockchip/Kconfig @@ -259,7 +259,7 @@ config SPL_ROCKCHIP_COMMON_BOARD no TPL for the board.
config TPL_ROCKCHIP_COMMON_BOARD - bool "" + bool "Rockchip TPL common board file" depends on TPL help Rockchip SoCs have similar boot process, prefer to use TPL for DRAM

This missing dependency seems like an oversight, since all other TPL_DM_* options have it.
Signed-off-by: Thomas Hebb tommyhebb@gmail.com --- drivers/serial/Kconfig | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/serial/Kconfig b/drivers/serial/Kconfig index d36a0108ea..ece7d87d4c 100644 --- a/drivers/serial/Kconfig +++ b/drivers/serial/Kconfig @@ -145,7 +145,7 @@ config SPL_DM_SERIAL
config TPL_DM_SERIAL bool "Enable Driver Model for serial drivers in TPL" - depends on DM_SERIAL + depends on DM_SERIAL && TPL_DM default y if TPL && DM_SERIAL help Enable driver model for serial in TPL. This replaces

On Sun, Nov 10, 2019 at 08:23:55AM -0800, Thomas Hebb wrote:
This missing dependency seems like an oversight, since all other TPL_DM_* options have it.
Signed-off-by: Thomas Hebb tommyhebb@gmail.com
Applied to u-boot/master, thanks!

On Sun, Nov 10, 2019 at 08:23:53AM -0800, Thomas Hebb wrote:
27084c03d36a ("spl: Allow tiny printf() to be controlled in SPL and TPL") split this option in two for TPL and SPL, but didn't change the Kconfig names, making them hard to set quickly.
Signed-off-by: Thomas Hebb tommyhebb@gmail.com
Applied to u-boot/master, thanks!
participants (2)
-
Thomas Hebb
-
Tom Rini