
Hello Andreas,
Am 06.11.2014 01:24, schrieb Andreas Bießmann:
Hi Heiko,
On 31.10.14 08:30, Heiko Schocher wrote:
This patchset add SPL support for the AT91SAM9G20 based taurus board, and the AT91SAM9M10G45 based corvus board from siemens, and replaces the at91bootstrap code.
The boot.bin which replaces the at91bootstrap image can created with mkimage:
./tools/mkimage -T atmelimage -d spl/u-boot-spl.bin spl/boot.bin
For other SoC this step is done in one step ... should we add this also for AT91 based boards?
For example add a "u-boot.at91" target in the Makefile?
This patchset is based on the common updates for the taurus and corvus board:
Patchwork [U-Boot] arm, at91: add generic board support for the taurus and corvus board http://patchwork.ozlabs.org/patch/395398/ (now in mainline)
Patchwork [U-Boot] arm, at91: add spi dataflash support for the taurus board http://patchwork.ozlabs.org/patch/395400/
Changes in v3: rebased against 571bdf16a78e9e116a93d46f4809c4f8a3f2adb6 add Reviewed-by from Bo Shen add Acked-by from Scott Wood add comment from Bo shen
- ignore 80 characters length as Bo Shen and Adreas Biessmann suggested
- fix AT91_PMC_MCKR_CSS_MASK and AT91_PMC_MCKR_PRES_MASK
- make matrix_init weak, and add it in the taurus board code
- do not introduce ifdef mess for the differences between the SoCs, instead use a seperate file for each SoC:
- for armv5 (arm926ejs, now at91 series), named it spl_at91.c,
- for armv7 (cortex-a5, now, sama5d3), named it spl_atmel.c
- move common code to arch/arm/cpu/at91-common/spl.c
Changes in v2:
- rebased against d58a9451e7339ed4cf2b2627e534611f427fb791
- spi, atmel: move CONFIG_SYS_SPI_WRITE_TOUT into common header new in v2
- add comment from Jagan Teki:
- remove spi_init_f() from board file
- remove CONFIG_SYS_SPI_WRITE_TOUT from board config file instead define a default in the spi driver -> new patch for v2
- add Reviewed-by: Andreas Bießmannandreas.devel@googlemail.com
- add comment from Andreas Biessmann: rename "MPDDRC_CR_EBISHARE" to "MPDDRC_CR_DQMS_SHARED"
- add comment from scott wood: move nand_erase_one into "include/nand.h" and rename it to spl_nand_erase_one
for me this series looks good. Lets wait for Jagan's Ok for '[v3 PATCH 02/12] arm, at91: add spi dataflash support for the taurus board', then I'll apply it this weekend or so.
Thanks for this info!
bye, Heiko