
Now that sandbox has <asm/barrier.h> and defines nop() there we should include that in our driver for clarity and then remove our local nop() from <k210/pll.h>.
Signed-off-by: Tom Rini trini@konsulko.com --- I can see that our ARM <asm/barriers.h> should be <asm/barrier.h> and updated in a few other ways to match how the kernel is currently. This is not a big deal yet as this driver is only for sandbox for risc-v
Cc: Sean Anderson seanga2@gmail.com --- drivers/clk/clk_k210.c | 1 + include/k210/pll.h | 3 --- 2 files changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/clk/clk_k210.c b/drivers/clk/clk_k210.c index c534cc07e092..b9469b93853b 100644 --- a/drivers/clk/clk_k210.c +++ b/drivers/clk/clk_k210.c @@ -16,6 +16,7 @@ #include <dt-bindings/mfd/k210-sysctl.h> #include <k210/pll.h> #include <linux/bitfield.h> +#include <asm/barrier.h>
DECLARE_GLOBAL_DATA_PTR;
diff --git a/include/k210/pll.h b/include/k210/pll.h index fd16a89cb203..175c47f6f233 100644 --- a/include/k210/pll.h +++ b/include/k210/pll.h @@ -16,9 +16,6 @@ struct k210_pll_config { #ifdef CONFIG_UNIT_TEST TEST_STATIC int k210_pll_calc_config(u32 rate, u32 rate_in, struct k210_pll_config *best); -#ifndef nop -#define nop() -#endif
#endif #endif /* K210_PLL_H */