
Dear Jean-Christophe PLAGNIOL-VILLARD,
In message 20090510141702.GA21079@game.jcrosoft.org you wrote:
In message 1241863009-26036-3-git-send-email-plagnioj@jcrosoft.com you wrote:
actually the console API use the following naming convention
Please look up the difference in meaning between "actually" and "cur- rently"; I think you usually mean "currently" when you say "actually".
This patch should preceed the previous one, where you already use the new, not yet introduced "stdio_" naming scheme.
======Extract====== typedef struct device_t;
int device_register (device_t * dev); int devices_init (void); int device_deregister(char *devname); struct list_head* device_get_list(void); device_t* device_get_by_name(char* name); device_t* device_clone(device_t *dev); =======
which is not console dependent and is confusing
I think this explanation is confusing, too, as I don't know whjat you mean by "console dependent".
device is a generic name
Can you please try and explain what you find confusing, and what you mean by "not console dependent"? I cannot even guess what you mean here.
-#define CONFIG_SYS_DEVICE_NULLDEV 1 +#if defined(CONFIG_SPLASH_SCREEN) && !defined(CONFIG_SYS_STDIO_NULLDEV) +#define CONFIG_SYS_STDIO_NULLDEV 1 #endif
I'm not happy about the CONFIG_SYS_STDIO_NULLDEV; the "NULL device" is actually a more general concept and not limited to the stdio handling. Please do not put a "STDIO" in this name.
here it's to active the stdio null device
No. If you are talking about "a more general concept" which is "not limited to the stdio handling", then we should do it right. Then there is no such thing as a "stdio null device". There is only a null device, and we assign it to one or more stdio channels here. Please do not name this "stdio null device" or ...STDIO_NULLDEV.
Best regards,
Wolfgang Denk