
This series : - Add new gpio ops get_function_number - Add get_function and get_function_number support to stm32 gpio driver - Add get_function_number test
Christophe Kerello (1): gpio: stm32f7: Add ops get_function
Patrice Chotard (2): gpio: sandbox: Rename GPIOF_(OUTPUT|HIGH|ODR) to SDBX_GPIO_(OUTPUT|HIGH|ODR) test: dm: Add gpio get_function_number ops test
Patrick Delaunay (2): dm: gpio: Add get_function_number ops gpio: stm32f7: Add ops get_function_number
arch/sandbox/include/asm/gpio.h | 23 ++++++++++++++++++++ drivers/gpio/gpio-uclass.c | 6 ++++++ drivers/gpio/sandbox.c | 47 +++++++++++++++++++++++++++++++---------- drivers/gpio/stm32f7_gpio.c | 36 +++++++++++++++++++++++++++++++ include/asm-generic/gpio.h | 11 ++++++++++ test/dm/gpio.c | 13 ++++++++++++ 6 files changed, 125 insertions(+), 11 deletions(-)