
On 10/03/2016 02:27 PM, Stefan Agner wrote:
On 03.10.2016 10:28, Stephen Warren wrote:
On 09/30/2016 04:00 AM, Marcel Ziswiler wrote:
On Wed, 2016-09-28 at 12:00 -0600, Stephen Warren wrote:
On 09/28/2016 03:35 AM, Marcel Ziswiler wrote:
Avoid a checkboard() name clash with our upcoming custom implementation thereof.
If you want to avoid naming conflicts, please simply name your new function something that doesn't conflict. That way it will avoid confusion is someone actually wants to enable the CONFIG_DISPLAY_BOARDINFO option themselves, plus it avoids taking the current feature set away.
No, it is not just any function. We do want our custom checkboard() to be called upon boot and not the Tegra generic one just printing a hard coded string.
I guess alternatively we could gate the checkboard() call in arch/arm/mach-tegra/board2.c with a
#if !defined(CONFIG_CUSTOM_BOARDINFO)
just as introduced a while ago in common/board_info.c
http://git.denx.de/?p=u-boot.git;a=blob;f=common/board_info.c;h=bd5dcfa 066358c2cc44ce5d19fcc3e77d555cd09;hb=HEAD#l20
in order to not print the hard coded name from the device tree.
I'd prefer to keep the behaviour standard across all Tegra boards. If you want to do additional actions in the checkboard() function, I suggest making it call an optional additional function:
__weak int tegra_checkboard(void) { return 0; }
int checkboard(void) { ... return tegra_checkboard(); }
Well that would print a message "Board: " ... twice, which is rather strange.
Surely you simply make tegra_checkboard() not contain duplicate code?
What do you think of my idea?
I'd rather not introduce any more ifdefs, but instead have a single path through the code-base.