
Dear Luca Ceresoli,
In message 1300707767-15682-2-git-send-email-luca.ceresoli@comelit.it you wrote:
Board support for the Comelit Group SpA CPS board, which is a custom board based on the BeagleBoard http://beagleboard.org/ by Texas Instruments.
The board support is based on the BeagleBoard implementation.
It appears you base this code on an old version of U-Boot. Please update your code base first.
ALso make sure to run your patch to checkpatch before submitting:
[PATCH] ARMV7: OMAP3: Add support for Comelit CPS board total: 4 errors, 325 warnings, 976 lines checked
Please fix these!
--- /dev/null +++ b/board/comelit/cps/config.mk
...
+CONFIG_SYS_TEXT_BASE = 0x80008000
We don't accept such config.mk files any more. Please move definition into your board config file.
- /* GPIO list
- 159 OUT (GPIO5+31): reset for remote camera interface connector.
- 19 OUT (GPIO1+19): integrated speaker amplifier (1=on, 0=shdn).
- 20 OUT (GPIO1+20): handset amplifier (1=on, 0=shdn).
- */
Incorrect multiline comment style.
...
--- a/boards.cfg +++ b/boards.cfg @@ -117,6 +117,7 @@ omap3_pandora arm armv7 pandora - igep0020 arm armv7 igep0020 isee omap3 igep0030 arm armv7 igep0030 isee omap3 am3517_evm arm armv7 am3517evm logicpd omap3 +omap3_cps arm armv7 cps comelit omap3 omap3_zoom1 arm armv7 zoom1 logicpd omap3 omap3_zoom2 arm armv7 zoom2 logicpd omap3 omap3_beagle arm armv7 beagle ti omap3
Please name your board just "cps" (or chose a better name). There shall be no SoC-prefix in the board names.
--- /dev/null +++ b/include/configs/omap3_cps.h @@ -0,0 +1,315 @@
...
+#define CONFIG_ARMV7 1 /* This is an ARM V7 CPU core */ +#define CONFIG_OMAP 1 /* in a TI OMAP core */ +#define CONFIG_OMAP34XX 1 /* which is a 34XX */ +#define CONFIG_OMAP3430 1 /* which is in a 3430 */ +#define CONFIG_OMAP3_CPS 1 /* working with CPS board */
#defines like these which select a feature shall not have values assigned. Remove all these '1' here. Please fix globally.
Best regards,
Wolfgang Denk