
Hi,
On 14-05-15 20:41, Ian Campbell wrote:
On Thu, 2015-05-14 at 18:55 +0200, Hans de Goede wrote:
+config DRAM_ODT_EN
- int "sunxi dram odt enable"
- default 0
- ---help---
- Set this to 1 to enable dram odt (on die termination)
Why is this an int rather than a bool?
Because it is used directly as an int in the code, otherwise I need to add #ifdef-ery. I guess I could make it a bool and use IS_ENABLED(), but that does lead to slightly less readable code IMHO.
I'm afraid I think IS_ENABLED is the way to go though, it's the lesser of two evils compared with using an int for a boolean option.
Ok, so while trying to fix this I noticed that there already is a definition of CONFIG_DRAM_ODT_EN in board/sunxi/Kconfig inside a
#if MACH_SUN4I || MACH_SUN5I || MACH_SUN7I
block, and that one actually really is an int (it goes from 0-3). so I'm going to leave this as an int, and use the existing option moving it outside of the #if MACH_SUN4I || MACH_SUN5I || MACH_SUN7I block.
v2 coming up.
Regards,
Hans