
On Thu, Jan 23, 2014 at 11:58:13AM -0700, Stephen Warren wrote: [...]
diff --git a/arch/arm/cpu/tegra-common/clock.c b/arch/arm/cpu/tegra-common/clock.c
[...]
@@ -575,3 +575,91 @@ void clock_init(void) /* Do any special system timer/TSC setup */ arch_timer_init(); }
+static void set_avp_clock_to(u32 src)
Perhaps a better name would be "set_avp_clock_source()"? _to had me confused at first because I assumed it would be setting a frequency.
+void tegra30_or_later_adjust_pllp(void)
I would've called this simply tegra30_adjust_pllp(), where it's implied that when you call tegra30_*() from code targetted at later generations these would be compatible with Tegra30.
But if you'd rather make it implicit that's fine too.
Either way:
Reviewed-by: Thierry Reding treding@nvidia.com Tested-by: Thierry Reding treding@nvidia.com Acked-by: Thierry Reding treding@nvidia.com
Thierry