
As platform uses GPIOs for card detection, it's simpler and more readable to use GPIO_ACTIVE_(LOW|HIGH) in the gpio flags instead of using the cd-inverted property.
Reported-by: Tuomas Tynkkynen tuomas.tynkkynen@iki.fi Signed-off-by: Patrice Chotard patrice.chotard@st.com ---
Changes in v3: - remove usage of "cd_inverted" DT property in dm_mmc_getcd()
Changes in v2: None
drivers/mmc/arm_pl180_mmci.c | 5 +---- drivers/mmc/arm_pl180_mmci.h | 1 - 2 files changed, 1 insertion(+), 5 deletions(-)
diff --git a/drivers/mmc/arm_pl180_mmci.c b/drivers/mmc/arm_pl180_mmci.c index 1cd780b3eec0..f71d79ecd6ba 100644 --- a/drivers/mmc/arm_pl180_mmci.c +++ b/drivers/mmc/arm_pl180_mmci.c @@ -499,11 +499,8 @@ static int dm_mmc_getcd(struct udevice *dev) struct pl180_mmc_host *host = dev->priv; int value = 1;
- if (dm_gpio_is_valid(&host->cd_gpio)) { + if (dm_gpio_is_valid(&host->cd_gpio)) value = dm_gpio_get_value(&host->cd_gpio); - if (host->cd_inverted) - return !value; - }
return value; } diff --git a/drivers/mmc/arm_pl180_mmci.h b/drivers/mmc/arm_pl180_mmci.h index 6b98db6cd978..36487be288b2 100644 --- a/drivers/mmc/arm_pl180_mmci.h +++ b/drivers/mmc/arm_pl180_mmci.h @@ -192,7 +192,6 @@ struct pl180_mmc_host { struct mmc_config cfg; #ifdef CONFIG_DM_MMC struct gpio_desc cd_gpio; - bool cd_inverted; #endif };