
3 Feb
2012
3 Feb
'12
1:42 p.m.
On Thursday 19 January 2012 19:53:29 Joe Hershberger wrote:
--- a/README +++ b/README
CONFIG_CMD_PCMCIA * PCMCIA support
CONFIG_CMD_PCMCIA * PCMCIA support
please omit unrelated whitespace changes
--- a/common/cmd_net.c +++ b/common/cmd_net.c
+int do_link_local(cmd_tbl_t *cmdtp, int flag, int argc, char * const
static
- NetOurGatewayIP = 0;
- ip_to_string(NetOurGatewayIP, tmp);
- setenv("gatewayip", tmp);
- ip_to_string(NetOurSubnetMask, tmp);
- setenv("netmask", tmp);
- ip_to_string(NetOurIP, tmp);
- setenv("ipaddr", tmp);
i feel like we should add a helper to do this setenv_ip("ipaddr", NetOurIP);
--- a/net/Makefile +++ b/net/Makefile
-COBJS := $(COBJS-y) +COBJS := $(sort $(COBJS-y))
why ?
--- a/net/arp.c +++ b/net/arp.c
+#if defined(CONFIG_CMD_LINK_LOCAL) +#include "link_local.h" +#endif
please push the ifdef down into the header -mike