
Hi Marek,
On 09/21/2014 04:44 PM, Marek Vasut wrote:
diff --git a/board/kosagi/novena/Makefile b/board/kosagi/novena/Makefile new file mode 100644 index 0000000..f67bbc9 --- /dev/null +++ b/board/kosagi/novena/Makefile @@ -0,0 +1,11 @@ +# +# Copyright (C) 2014 Marek Vasutmarex@denx.de +# +# SPDX-License-Identifier: GPL-2.0+ +#
+ifndef CONFIG_SPL_BUILD +obj-y := novena.o +else +obj-y := novena_spl.o +endif
What do you say about using only "positive" descriptions instead of the negation, like this:
ifdef CONFIG_SPL_BUILD obj-y := novena_spl.o else obj-y := novena.o endif
In long term people tend to misunderstand the negations, and sometimes (unfortunately) start to build additional negations on top, so it's hard to follow the logic in the end.
One more comment - isn't the file novena.o used also for the TPL, when building for SPL?
Kind regards, Nikolay