
6 May
2009
6 May
'09
7:35 p.m.
On Wed, May 06, 2009 at 09:05:21AM -0400, Mike Frysinger wrote:
- NAND_PLAT_WRITE_CMD(cmd, chip)
- NAND_PLAT_WRITE_ADR(cmd, chip)
It seems counterintuitive to have "cmd" before "this" -- it's backwards from both cmd_ctrl and the blackfin command that you turn it into (yes, it's like writeb() -- but I always found that to be weird too).
+/* #define CONFIG_NAND_PLAT */
Why is this commented out?
+#define NAND_PLAT_DEV_READY(chip) ((*pPORTFIO & BFIN_NAND_READY) ? 1 : 0)
Why not just (*pPORTFIO & BFIN_NAND_READY)?
-Scott