
This test doesn't belong at the top level. Move it into the lib/ directory, to match its implementation. Rename it to drop the unnecessary _ut suffix.
Signed-off-by: Simon Glass sjg@chromium.org ---
test/Makefile | 1 - test/lib/Makefile | 1 + test/{time_ut.c => lib/time.c} | 0 3 files changed, 1 insertion(+), 1 deletion(-) rename test/{time_ut.c => lib/time.c} (100%)
diff --git a/test/Makefile b/test/Makefile index 0b1affcf445..47a07d653a9 100644 --- a/test/Makefile +++ b/test/Makefile @@ -14,7 +14,6 @@ endif ifneq ($(CONFIG_HUSH_PARSER),) obj-$(CONFIG_$(XPL_)CMDLINE) += hush/ endif -obj-$(CONFIG_UT_TIME) += time_ut.o obj-y += ut.o
ifeq ($(CONFIG_XPL_BUILD),) diff --git a/test/lib/Makefile b/test/lib/Makefile index c36c8b0917d..217c3baf881 100644 --- a/test/lib/Makefile +++ b/test/lib/Makefile @@ -27,6 +27,7 @@ obj-$(CONFIG_AES) += test_aes.o obj-$(CONFIG_GETOPT) += getopt.o obj-$(CONFIG_CRC8) += test_crc8.o obj-$(CONFIG_UT_LIB_CRYPT) += test_crypt.o +obj-$(CONFIG_UT_TIME) += time.o obj-$(CONFIG_$(XPL_)UT_UNICODE) += unicode.o obj-$(CONFIG_LIB_UUID) += uuid.o else diff --git a/test/time_ut.c b/test/lib/time.c similarity index 100% rename from test/time_ut.c rename to test/lib/time.c