
On 1 May 2016 at 11:35, Simon Glass sjg@chromium.org wrote:
This started as 'ahci' and was renamed to 'disk' during code review. But it seems that this is too generic. Now that we have a 'blk' uclass, we can use that as the generic piece, and revert to ahci for this.
Signed-off-by: Simon Glass sjg@chromium.org
Changes in v2: None
arch/x86/Kconfig | 3 +++ arch/x86/cpu/broadwell/sata.c | 2 +- arch/x86/cpu/intel_common/cpu.c | 2 +- arch/x86/cpu/ivybridge/bd82x6x.c | 2 +- arch/x86/cpu/ivybridge/sata.c | 2 +- drivers/block/Kconfig | 5 ++--- drivers/block/Makefile | 2 +- drivers/block/{disk-uclass.c => ahci-uclass.c} | 6 +++--- include/dm/uclass-id.h | 2 +- 9 files changed, 14 insertions(+), 12 deletions(-) rename drivers/block/{disk-uclass.c => ahci-uclass.c} (72%)
Applied to u-boot-dm.