
On Apr 6, 2013, at 12:01 AM, Wolfgang Denk wrote:
Dear York Sun,
In message 515F5812.8030008@freescale.com you wrote:
adding new:
dcache flush => flush all dcache flush <addr> <size> => flush range
I think this makes more sense. Comments?
It would if the command only deals with dcache. This command flushes dcache _and_ invalidates icache.
Then the name "flush" is even more a bad choice.
If "flush_cache" is acceptable, we can use v2. If not, please suggest one. My candidates are "flushcache", "cacheflush".
Can we not split this into:
dcache flush icache invalidate
? This would make clear what's happening.
The idea is to reuse existing code with minimum addition. For the applications concerned, these two steps are both needed. Splitting them doesn't make things easier. If I have to use existing command, I'd rather to put these two steps under icache invalide <addr> <size>.
York