
14 Dec
2018
14 Dec
'18
4:35 p.m.
The current dev_read...() functions use s32 and u32 which are convenient for device tree but not so useful for normal code, which often wants to use normal integers for values.
Add a helper which supports returning an unsigned int. Also add signed versions of the unsigned readers.
Signed-off-by: Simon Glass sjg@chromium.org ---
Changes in v2: None
arch/sandbox/dts/test.dts | 2 ++ drivers/core/read.c | 23 ++++++++++++++++ include/dm/read.h | 58 +++++++++++++++++++++++++++++++++++++++ test/dm/test-fdt.c | 35 +++++++++++++++++++++++ 4 files changed, 118 insertions(+)
Applied to u-boot-dm/master