
The code that produces the migration warnings is quite tedious to understanding and modify. This series updates it to use a common function to handle the logic, so that the message definition is quite short and has no duplication in it.
It is still necessary to write a message in migration.rst however.
This series came out of a patch intended to add an I2C warning.
It also renames CONFIG_DM_RESET; it does not need to be migrated since it already uses driver model.
Changes in v4: - Refactored the warning code to make it easier to get this right - Add GPIO deprecation as well - Add patches to rename DM_RESET to RESET
Changes in v3: - s/'network'/I2C/ again
Changes in v2: - s/'network'/I2C/
Simon Glass (14): Makefile: Move non-DM migration messages to the top Makefile: Add common code to report deprecation Makefile: Use common code for MMC deprecation warning Makefile: Use common code for USB deprecation warning Makefile: Use common code for MVSATA_IDE deprecation warning Makefile: Use common code for LIBATA deprecation warning Makefile: Use common code for PCI deprecation warning Makefile: Use common code for DM_VIDEO deprecation warning Makefile: Use common code for SPI_FLASH deprecation warning Makefile: Use common code for WDT deprecation warning Makefile: Use common code for DM_ETH deprecation warning Makefile: Drop the old SPI flash migration message dm: i2c: Add a migration method for I2C dm: gpio: Add a migration message for GPIO
Makefile | 157 +++++++++++---------------------- doc/driver-model/migration.rst | 16 ++++ 2 files changed, 67 insertions(+), 106 deletions(-)