
Dear Stefan Roese,
In message 200905131620.39726.sr@denx.de you wrote:
-static void ide_ident (block_dev_desc_t *dev_desc); -static uchar ide_wait (int dev, ulong t); +static void ide_ident(block_dev_desc_t * dev_desc);
And I really hate the space after the '*' in lines like these,
I don't like then too. I'm wondering why indent didn't do this consistent.
especially as it's done more or lessa randomly:
-static void atapi_inquiry(block_dev_desc_t *dev_desc); -ulong atapi_read (int device, lbaint_t blknr, ulong blkcnt, void *buffer); +static void atapi_inquiry(block_dev_desc_t * dev_desc); +ulong atapi_read(int device, lbaint_t blknr, ulong blkcnt, void *buffer);
We have "* dev_desc", but "*buffer" ? That's just bogus.
- printf ("\nLoading from IDE device %d, partition %d: "
"Name: %.32s Type: %.32s\n",
dev, part, info.name, info.type);
- printf("\nLoading from IDE device %d, partition %d: "
"Name: %.32s Type: %.32s\n", dev, part, info.name, info.type);
Also, reordering the lines here makes the code more difficult to read.
- if (ide_dev_desc[dev].block_read (dev, info.start, 1, (ulong *)addr) !=
- { - printf ("** Read error on %d:%d\n", dev, part);
show_boot_progress (-48);
- if (ide_dev_desc[dev].block_read(dev, info.start, 1, (ulong *) addr) !=
- {
Why is there a space after the cast?
No idea. I'll try to remove all those spaces.
I can only speculate that Lindent understands about basic data types (void *, int *, etc.), and inserts NO space there, but it does not understand things like "ulong" or "block_dev_desc_t" and does insert a space there.
Why this would make any sense to anybody I cannot tell.
OK, I'll try to fix all those issues and resubmit a new version.
Thanks.
Best regards,
Wolfgang Denk