
2 Dec
2015
2 Dec
'15
10:30 a.m.
With driver model timer support, there should not be an explict call to timer_init(). Remove this call for x86.
Signed-off-by: Bin Meng bmeng.cn@gmail.com ---
common/board_f.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/common/board_f.c b/common/board_f.c index b035c90..92c42c5 100644 --- a/common/board_f.c +++ b/common/board_f.c @@ -807,7 +807,7 @@ static init_fnc_t init_sequence_f[] = { /* TODO: can we rename this to timer_init()? */ init_timebase, #endif -#if defined(CONFIG_X86) || defined(CONFIG_ARM) || defined(CONFIG_MIPS) || \ +#if defined(CONFIG_ARM) || defined(CONFIG_MIPS) || \ defined(CONFIG_BLACKFIN) || defined(CONFIG_NDS32) timer_init, /* initialize timer */ #endif
--
1.8.2.1