
On 03/18/15 09:37, Hannes Petermaier wrote:
From: Hannes Petermaier hannes.petermaier@br-automation.com
For coming implementation of lcd_console rotation, we will need some more variables for holding information about framebuffer size, rotation, ...
For better readability we catch all them into a common structure.
Signed-off-by: Hannes Petermaier hannes.petermaier@br-automation.com Signed-off-by: Hannes Petermaier oe5hpm@oevsv.at
Changes in v2: None
common/lcd_console.c | 76 +++++++++++++++++++++++++------------------------- 1 file changed, 38 insertions(+), 38 deletions(-)
diff --git a/common/lcd_console.c b/common/lcd_console.c index b7dda7a..cac77be 100644 --- a/common/lcd_console.c +++ b/common/lcd_console.c
[...]
+struct console_t {
- short curr_col, curr_row;
- short cols, rows;
- void *lcd_address;
Shouldn't this be fbbase?
+}; +static struct console_t cons;
[...]