
On Wed, 4 Jan 2017, Michal Simek wrote:
I looked at this. Correct name should be CONFIG_CMD_MX_CYCLIC and for the rest s/CONFIG_MX_CYCLIC/CONFIG_CMD_MX_CYCLIC/g with move to defconfig.
- in Kconfig there should be dependecy on CMD_MEMORY.
for better or worse, i ran that cleanup script and posted the output here:
http://www.crashcourse.ca/wiki/index.php/U-Boot_Kconfig_cleanup
that list is *allegedly* variables that are defined in some Kconfig file, but are never tested anywhere in the code. the output isn't perfect, there are a bunch of false positives since what i consider a variable being "tested" is if, somewhere in the code base, there is a RE of the form:
"if.*<variable name>"
that script worked pretty well on kernel code, but doesn't take into account testing in the u-boot source involving "$(SPL_)" variants or testing with "CONFIG_IS_ENABLED", or config variables whose only purpose in life is to further "select" other variables.
in any case, the output isn't that lengthy, feel free to look through it to see if anything looks familiar. i've got a couple other scripts i'm going to run on the code base shortly.
rday
p.s. that output allegedly represents variables that are defined in a Kconfig file but are never tested, which is typically not considered that big a deal -- that normally happens when one removes a feature but forgets to remove the Kconfig variable corresponding to it.
i have a second script that identified the opposite -- Kconfig variables that *are* being tested but do not seem to be defined in any Kconfig file, normally a more serious issue.