
On Sat, May 09, 2020 at 09:56:09PM +0530, Jagan Teki wrote:
Hi Tom,
Please pull this PR.
Summary:
- zap lpc32xx_ssp driver (Jagan)
- rename of phy nodev call (Jagan)
- iopoll with sleep_us (Jagan)
- MX25R6435F flash (Ye Li)
Travis-CI: https://travis-ci.org/github/openedev/u-boot-amarula/builds/684188097
The following changes since commit 67887903afc3615070dd878f6e0420d34b30274c:
Merge branch '2020-05-07-atheros-phy-improvements' (2020-05-07 14:51:44 -0400)
are available in the Git repository at:
https://gitlab.denx.de/u-boot/custodians/u-boot-spi spi
for you to fetch changes up to 9e880f36dfab0fb8d856cffd4b8b9e34c4c2c7a6:
sf: Add Macronix MX25R6435F SPI NOR flash to flash parameters array (2020-05-08 00:52:50 +0530)
Dario Binacchi (1): spi: fix dev parameter in dev_* calls
Jagan Teki (7): spi: Zap lpc32xx_ssp driver-related code phy: Fix node description of phy_get_by_node phy: Use _nodev naming convention if non-device clients clk: Fix clk func names in comments iopoll: Add read_poll_timeout common API iopoll: Add dealy to read poll iopoll: Add readl_poll_sleep_timeout
Kuldeep Singh (1): spi: nxp-fspi: Use new readl_poll_sleep_timeout API
Ye Li (1): sf: Add Macronix MX25R6435F SPI NOR flash to flash parameters array
arch/arm/mach-meson/board-gx.c | 3 +- drivers/mtd/spi/spi-nor-core.c | 19 +++--- drivers/mtd/spi/spi-nor-ids.c | 1 + drivers/phy/phy-uclass.c | 4 +- drivers/spi/Kconfig | 6 -- drivers/spi/Makefile | 1 - drivers/spi/lpc32xx_ssp.c | 134 ----------------------------------------- drivers/spi/nxp_fspi.c | 10 +-- include/clk.h | 12 ++-- include/configs/devkit3250.h | 5 -- include/configs/work_92105.h | 5 -- include/generic-phy.h | 9 ++- include/linux/iopoll.h | 16 ++++- scripts/config_whitelist.txt | 1 - 14 files changed, 47 insertions(+), 179 deletions(-) delete mode 100644 drivers/spi/lpc32xx_ssp.c
For a small PR it has a ton of conflicts, can you please rebase it? Thanks!