
Hi Simon,
On 2024-09-28 22:00, Simon Glass wrote:
Now that SPL means SPL (only) and is not defined for other phases, update kconfig rules.
Signed-off-by: Simon Glass sjg@chromium.org
(no changes since v1)
include/linux/kconfig.h | 10 +++++----- tools/binman/test/generated/autoconf.h | 2 +- 2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/include/linux/kconfig.h b/include/linux/kconfig.h index a59f2a61e6a..ec9584b2426 100644 --- a/include/linux/kconfig.h +++ b/include/linux/kconfig.h @@ -40,7 +40,7 @@ #define _CONFIG_PREFIX TPL_ #elif defined(CONFIG_VPL_BUILD) #define _CONFIG_PREFIX VPL_ -#elif defined(CONFIG_XPL_BUILD) +#elif defined(CONFIG_SPL_BUILD)
This change back from XPL to SPL is probably not needed it you did not change it to XPL in the first place.
Just doing a mass search and replace is making this series hard to review.
Personally I did not fully realize that SPL_ or SPL_BUILD meant any xPL build before this series, so I would look at each SPL_BUILD to XPL_BUILD and SPL_ to XPL_ change and try to understand the original intent.
I know multiple places where I have used SPL_ and not SPL_TPL_ because of this, and similar have used SPL_BUILD for parts I only want in SPL and not in TPL.
How should I best handle sending fixes where I e.g. have used SPL_ in Makefile that instead should be changed to SPL_TPL_/PHASE_ and similar avoid a change to XPL_BUILD because the original intent was just for SPL?
I will also suggest you rearrange some of you patches to make this more reviewable and possible also make git bisect easier, maybe:
- any fixes not involving XPL first, e.g. _SPL to _SPL_TPL in Makefile, SPL_BUILD in Kconfig etc - add XPL_BUILD symbol - all fixes and cleanup involving XPL_BUILD symbol - rename and use spl_ to xpl_ functions - doc updates - replace SPL_BUILD with XPL_BUILD in code, preferably in multiple smaller logical patches instead of a single big patch - remove SPL_BUILD for TPL and VPL - rename SPL_ to XPL_ in Makefile - rename SPL_TPL_ to PHASE_ in Makefile, NAME and PROMPT
or something similar instead of doing the big search and replace early.
Regards, Jonas
#define _CONFIG_PREFIX SPL_ #else #define _CONFIG_PREFIX @@ -54,7 +54,7 @@
- CONFIG_VAL(FOO) evaluates to the value of
- CONFIG_TOOLS_FOO if USE_HOSTCC is defined,
- CONFIG_FOO if CONFIG_XPL_BUILD is undefined,
- CONFIG_SPL_FOO if CONFIG_XPL_BUILD is defined.
*/
- CONFIG_SPL_FOO if CONFIG_SPL_BUILD is defined.
- CONFIG_TPL_FOO if CONFIG_TPL_BUILD is defined.
- CONFIG_VPL_FOO if CONFIG_VPL_BUILD is defined.
@@ -107,21 +107,21 @@ long invalid_use_of_IF_ENABLED_INT(void);
- CONFIG_IS_ENABLED(FOO) expands to
- 1 if USE_HOSTCC is defined and CONFIG_TOOLS_FOO is set to 'y',
- 1 if CONFIG_XPL_BUILD is undefined and CONFIG_FOO is set to 'y',
- 1 if CONFIG_XPL_BUILD is defined and CONFIG_SPL_FOO is set to 'y',
- 1 if CONFIG_SPL_BUILD is defined and CONFIG_SPL_FOO is set to 'y',
- 1 if CONFIG_TPL_BUILD is defined and CONFIG_TPL_FOO is set to 'y',
- 0 otherwise.
- CONFIG_IS_ENABLED(FOO, (abc)) expands to
- abc if USE_HOSTCC is defined and CONFIG_TOOLS_FOO is set to 'y',
- abc if CONFIG_XPL_BUILD is undefined and CONFIG_FOO is set to 'y',
- abc if CONFIG_XPL_BUILD is defined and CONFIG_SPL_FOO is set to 'y',
- abc if CONFIG_SPL_BUILD is defined and CONFIG_SPL_FOO is set to 'y',
- abc if CONFIG_TPL_BUILD is defined and CONFIG_TPL_FOO is set to 'y',
- nothing otherwise.
- CONFIG_IS_ENABLED(FOO, (abc), (def)) expands to
- abc if USE_HOSTCC is defined and CONFIG_TOOLS_FOO is set to 'y',
- abc if CONFIG_XPL_BUILD is undefined and CONFIG_FOO is set to 'y',
- abc if CONFIG_XPL_BUILD is defined and CONFIG_SPL_FOO is set to 'y',
- abc if CONFIG_SPL_BUILD is defined and CONFIG_SPL_FOO is set to 'y',
- abc if CONFIG_TPL_BUILD is defined and CONFIG_TPL_FOO is set to 'y',
- def otherwise.
diff --git a/tools/binman/test/generated/autoconf.h b/tools/binman/test/generated/autoconf.h index 75af48f9116..6a23039f469 100644 --- a/tools/binman/test/generated/autoconf.h +++ b/tools/binman/test/generated/autoconf.h @@ -1,3 +1,3 @@ #define CONFIG_BINMAN 1 -#define CONFIG_XPL_BUILD 1 +#define CONFIG_SPL_BUILD 1 #define CONFIG_SPL_BINMAN_SYMBOLS 1