
Hi Simon, please see below...
On Tue, Jun 28, 2016 at 08:28:07PM -0700, Simon Glass wrote:
On 27 June 2016 at 07:19, Andreas Dannenberg dannenberg@ti.com wrote:
diff --git a/include/image.h b/include/image.h index d788c26..93d39e1 100644 --- a/include/image.h +++ b/include/image.h @@ -1173,4 +1173,21 @@ void android_print_contents(const struct andr_img_hdr *hdr); */ int board_fit_config_name_match(const char *name);
+#ifdef CONFIG_SPL_FIT_IMAGE_POST_PROCESS +/**
- board_fit_image_post_process() - Do any post-process on FIT binary data
- This is used to do any sort of image manipulation, verification, decryption
- etc. in a platform or board specific way. Obviously, anything done here would
- need to be comprehended in how the images were prepared before being injected
- into the FIT creation (i.e. the binary blobs would have been pre-processed
- before being added to the FIT image).
- @image: pointer to the image start pointer
- @size: pointer to the image size
- @return no return value (failure should be handled internally)
- */
+void board_fit_image_post_process(void **p_image, size_t *p_size); +#endif /* CONFIG_SPL_FIT_IMAGE_POST_PROCESS */
We don't need #ifdef in header files - it just makes the code harder to read, and we'll still get a build error (with correct line number info) if someone uses it when they should not.
You are right that's technically not needed, but rather I was following how other prototypes are defined in that header file (like the ones that get declared when CONFIG_ANDROID_BOOT_IMAGE is defined).
For now I'm not planning to re-spin the patch series, but if there is additional feedback I can take care of this one as well.
Thanks and Regards,
-- Andreas Dannenberg Texas Instruments Inc