
Dear "Jason Hobbs",
In message 1314805054-16250-10-git-send-email-jason.hobbs@calxeda.com you wrote:
Add pxe command, which is intended to mimic PXELINUX functionality. 'pxe get' uses tftp to retrieve a file based on UUID, MAC address or IP address. 'pxe boot' interprets the contents of PXELINUX config like file to boot using a specific initrd, kernel and kernel command line.
This patch also adds a README.pxe file - see it for more details on the pxe command.
Signed-off-by: Jason Hobbs jason.hobbs@calxeda.com
changes in v2:
- call abortboot directly instead of via a wrapper
- change the license to GPLv2+
- cleanup brace usage in multiline statements, conditionals
- allow bootfile to not exist, or to be a standalone filename
- try to clarify what's going on with get_relfile
- try cfg paths one by one instead of building an array
- refactor getenv/printfs to a new from_env function
- use the new generic menu code instead of that being integrated
- drop the ifdef from do_tftp in common.h
- use a clearer comment wrt to localcmd dup
- default to no timeout
changes in v3:
- use GPLv2+ license for the readme
- parse and create menu in separate steps
- adapt to menu interface changes
changes in v4:
- rename pxecfg to pxe
- expose run_command2 externally when using pxe
- add more comments to common/cmd_pxe.c
- format_mac_pxe's outbuf is now allocated in its caller
- get_bootfile_path now takes bootfile_path from caller
- drop a redundant file not found message
- make printf messages more informative
- use sizeof(struct blah) instead of sizeof(*p)
- use memset to initialize some structs per wd's request
- use isblank to check for non EOL whitespace
- switch to standard subcommand handling
- fix regression where ctrl+c didn't return to command line
- check for filesize missing after a tftp get
- only call do_bootm with argc == 4 if fdtaddr != NULL (thanks Ricardo Salveti)
- use lowercase hex in formatted MAC string (thanks Loïc Minier)
- prefix MAC strings with "01-" to indicate Ethernet hwtype (thanks Loïc Minier)
- switch to the standard environment variables
- switch from simple to strict strtoul where possible
changes in v5:
- convert another simple_strtoul to strict
common/Makefile | 1 + common/cmd_pxe.c | 1355 ++++++++++++++++++++++++++++++++++++++++++++++++++++++ common/main.c | 2 + doc/README.pxe | 240 ++++++++++ include/common.h | 6 + 5 files changed, 1604 insertions(+), 0 deletions(-) create mode 100644 common/cmd_pxe.c create mode 100644 doc/README.pxe
Applied, thanks.
Best regards,
Wolfgang Denk