
On 03/14/2014 02:15 PM, Simon Glass wrote:
Hi Stephen,
On 13 March 2014 11:42, Stephen Warren swarren@wwwdotorg.org wrote:
From: Stephen Warren swarren@nvidia.com
Clean up the naming of pinmux-related objects:
- Refer to drive groups rather than pad groups to match the Linux kernel.
- Ensure all pinmux API types are prefixed with pmux_, values (defines) are prefixed with PMUX_, and functions prefixed with pinmux_.
- Modify a few type names to make their content clearer.
- Minimal changes to SoC-specific .h/.c files are made so the code still compiles. A separate per-SoC change will be made immediately following, in order to keep individual patch size down.
diff --git a/arch/arm/include/asm/arch-tegra114/pinmux.h b/arch/arm/include/asm/arch-tegra114/pinmux.h
@@ -202,10 +202,10 @@ enum pmux_pingrp { PINGRP_SDMMC3_CLK_LB_IN, PINGRP_SDMMC3_CLK_LB_OUT, PINGRP_RESET_OUT_N = PINGRP_SDMMC3_CLK_LB_OUT + 2,
PINGRP_COUNT,
PMUX_PINGRP_COUNT,
It seems odd that this doesn't match the others. Why not a PMUX_ prefix on all of them? Same comment in other cases below.
This is fixed in the per-SoC patches that follow, which replace the contents of all the data tables with fresh content. Logically, those patches are also part of this patch, but I split them up into a core patch which made minimal changes to the per-SoC files, and per-SoC patches, simply to keep the patch size down.
I'll look into your other comments when I get back on Wednesday; I have a short trip planned:-)