
Up to now we have treated handles as separate objects to EFI objects. This confusion has lead to hidden bugs like those corrected by the first patch. By changing the efi_handle_t typedef we can avoid this problem in future.
As handles are pointers to EFI objects there is no need for a handle member in struct efi_object. This allows to simplify our coding.
v3 rename parent to header rename image_handle to image_obj v2 replace remaining parent.handle in efi_disk.c
Heinrich Schuchardt (3): efi_loader: typedef struct efi_object *efi_handle_t efi_loader: eliminate handle member efi_loader: rename parent to header
cmd/bootefi.c | 28 ++++---- include/efi.h | 2 +- include/efi_api.h | 8 +-- include/efi_loader.h | 35 +++++++--- lib/efi/efi.c | 2 +- lib/efi_loader/efi_boottime.c | 79 +++++++++++----------- lib/efi_loader/efi_console.c | 20 +++--- lib/efi_loader/efi_device_path.c | 2 +- lib/efi_loader/efi_disk.c | 42 ++++++------ lib/efi_loader/efi_gop.c | 21 ++++-- lib/efi_loader/efi_net.c | 22 +++--- lib/efi_selftest/efi_selftest_devicepath.c | 2 +- 12 files changed, 146 insertions(+), 117 deletions(-)